Bug 119198 - Wrong Chapter Numbering with specific ODT
Summary: Wrong Chapter Numbering with specific ODT
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chapter-Numbering
  Show dependency treegraph
 
Reported: 2018-08-10 12:28 UTC by perlancar
Modified: 2019-09-06 12:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
test-paragraph-numbering-reset.odt (57.72 KB, application/vnd.oasis.opendocument.text)
2018-08-10 12:29 UTC, perlancar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description perlancar 2018-08-10 12:28:15 UTC
Description:
Paragraph numbering reset even though the style does not instruct to reset numbering.

Steps to Reproduce:
I'm sorry I couldn't reproduce from scratch despite trying several combinations. This happens on a document that I'm working on. But I've managed to simplify the document to the minimum (attached).

1. Open the attached document.

2. Go to the line that says "Test".

3. Press Ctrl-2 to set paragraph style to Heading 2. 

Actual Results:
The numbering for the paragraph is "1.1".

Expected Results:
It should be "1.2" because "1.1" is already taken by the previous Heading 2.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 perlancar 2018-08-10 12:29:00 UTC
Created attachment 144087 [details]
test-paragraph-numbering-reset.odt
Comment 2 Dieter 2018-08-13 09:40:30 UTC
I confirm it with

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 0a1a4ffb4f87adff7fbbbc60202b6a0e42fedd0c
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-08-08_23:17:46
Locale: en-US (de_DE); Calc: CL

I changed the summary, because I think "chapter numbering" is more adequate.
Comment 3 Xisco Faulí 2018-08-14 14:01:01 UTC
I can reproduce it back to

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

Anyway, it's difficult to analyze this bug if there are not steps to reproduce it from scratch...
Comment 4 QA Administrators 2019-08-19 06:56:24 UTC Comment hidden (obsolete)
Comment 5 Timur 2019-09-06 12:00:12 UTC
Congrats to reporter that confused two experienced QAs :)

We see:
        1.1  Subchapter 1 (list style WWNum2 with spaces)
Some text.
Test
1.1  Subchapter 2 (list style Bullet -)

That should give a hunt something is not right, two 1.1.
Go to List Styles and see they are different.

I cannot says how this was created but this document's numbering is wrong. 
I'll close as not LO bug.
Comment 6 Timur 2019-09-06 12:02:07 UTC
Note: if we have steps to create similar situation and use case where this can happen, that may be a bug, if not already reported.