Bug 119199 - Selected choice of available fonts
Summary: Selected choice of available fonts
Status: RESOLVED DUPLICATE of bug 91130
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.6.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fonts-Name-Combobox
  Show dependency treegraph
 
Reported: 2018-08-10 12:32 UTC by telrxr
Modified: 2018-08-17 09:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description telrxr 2018-08-10 12:32:39 UTC
Description:
Let LibreOffice only display a user-chosen list of available fonts. All system fonts are displayed, even those for languages I never use. Yet, these fonts cannot be removed system-wide, since KDE depends on them.

A feature for excluding unused/unwanted fonts from the formatting toolbar would be very useful

Actual Results:
All fonts are displayed (ie. Tens of Noto fonts for all languages)

Expected Results:
Either only a list of selected fonts, or, a user selection of fonts at the top of the list (not the short, "last used fonts" found at the top, but a user selected one)


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.0.6.2
Build ID: 1:6.0.6-0ubuntu0.16.04.1
Threads CPU : 4; OS : Linux 4.15; UI Render : par défaut; VCL: kde4; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 1 Dieter Praas 2018-08-15 17:26:58 UTC
Topic is discussed her: https://design.blog.documentfoundation.org/2018/02/18/improvements-font-listing/
Comment 2 Dieter Praas 2018-08-16 19:02:06 UTC
Heiko, I assume, that you can assess this proposal

Cc: Heiko Tietze
Comment 3 Heiko Tietze 2018-08-17 08:17:21 UTC
(In reply to Dieter Praas from comment #2)
> Heiko, I assume, that you can assess this proposal

The UX team does the assessment, I give only my opinion. And about this ticket, the best is to make it a dup of bug 91130. Agreed, telrxr?
Comment 4 telrxr 2018-08-17 08:36:18 UTC
Agreed !

Thanks
Comment 5 Dieter Praas 2018-08-17 09:11:51 UTC

*** This bug has been marked as a duplicate of bug 91130 ***