Bug 119218 - CONFIGURATION Autocorrect Options bullet symbol selection from "Favorite Characters" list does not work
Summary: CONFIGURATION Autocorrect Options bullet symbol selection from "Favorite Char...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Options-Dialog AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2018-08-11 16:31 UTC by Paul
Modified: 2019-03-22 06:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of "Bullet symbol: " in options menu (46.71 KB, image/png)
2018-08-28 01:56 UTC, Paul
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul 2018-08-11 16:31:30 UTC
Description:
Using the menu: 
Tools -> Autocorrect -> Autocorrect Options -> Bulleted and numbered lists. Bullet symbol: *
Then click "Edit" and in the special characters window if a character from the "Favorite Characters" list is selected then the "Bullet symbol" does not change.


Steps to Reproduce:
1. Click on Tools -> Autocorrect -> Autocorrect Options -> Bulleted and numbered lists. Bullet symbol: *
2. click "Edit" 
3. Select a character from the "Favorite Characters" list which is different than the character currently selected.


Actual Results:
currently selected character doesn't change.


Expected Results:
Bullet symbol character changes to the selected character


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 6.0.3.2
Build ID: 1:6.0.3-0ubuntu1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Paul 2018-08-11 16:41:01 UTC
Sometimes get this error:
(soffice:7707): GLib-GObject-WARNING **: 11:36:44.155: ../../../../gobject/gsignal.c:3492: signal name 'selection_changed' is invalid for instance '0x560914d59ee0' of type 'OOoAtkObjCompTxt'
But it seems not tied to the described problem and may be a related issue.
Comment 2 Dieter Praas 2018-08-27 07:02:39 UTC
(In reply to Paul from comment #0)

> Actual Results:
> currently selected character doesn't change.

Do you mean the preview in the dialog?

I can't confirm this with

Version: 6.0.6.2 (x64)
Build-ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 3 Paul 2018-08-28 01:56:13 UTC
Created attachment 144491 [details]
screenshot of "Bullet symbol: " in options menu

If a symbol from the "favorites" list of symbols is selected, the bullet symbol as shown in attachment, will not change.
Comment 4 Paul 2018-08-28 01:58:17 UTC
No the preview symbol in the character selector will change. The symbol shown in the options menu after the text "Bullet symbol: <your symbol>" will not change if you had selected that symbol from the "Favorites" list. 

In the attached screenshot the circle with a dot in it is the currently selected bullet symbol. That is what would not have changed.
Comment 5 Dieter Praas 2018-08-28 05:52:00 UTC
Thank you for clarification. But I can't reproduce it with

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 414ef6cb187dd3bbcc917dbedf3c0c1cc8668f60
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-08-21_00:13:04
Locale: en-US (de_DE); Calc: CL
Comment 6 raal 2018-09-08 06:58:34 UTC
Works for me at Version: 6.2.0.0.alpha0+
Build ID: 4b5fcd417587cfb9e6d8b61ecb037ab165eeb5b9
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3; 

Seems to be fixed with dev version. Please could you test it with
dev version?  You can download it here:
http://dev-builds.libreoffice.org/daily/master/
Thank you
Comment 7 QA Administrators 2019-03-21 11:11:37 UTC Comment hidden (obsolete)
Comment 8 Paul 2019-03-22 00:58:43 UTC
Verified this is fixed in later versions. 6.0.7.3 definitely fixes it.