Bug 119220 - Long CPU spike when adding a new bullet (see comment 5)
Summary: Long CPU spike when adding a new bullet (see comment 5)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-11 18:17 UTC by Telesto
Modified: 2018-11-29 13:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (26.31 KB, application/vnd.oasis.opendocument.text)
2018-08-11 18:17 UTC, Telesto
Details
Screenshot (7.25 KB, image/png)
2018-08-13 08:00 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-08-11 18:17:12 UTC
Description:
Long CPU spike when adding a new bullet. Could be nothing. Only observed in 2018-08-10

Steps to Reproduce:
1. Open the attached file
2. Scroll down last page
3. CTRL+END
4. Press Enter after "Peu"

Actual Results:
Long CPU bump

Expected Results:
No long CPU bump


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 6.2.0.0.alpha0+
Build ID: c958f52b813d34baa9b5236bb34a08a04e6b0aba
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-08-10_04:55:45
Locale: en-US (nl_NL); Calc: CL

but not in
Version: 6.2.0.0.alpha0+
Build ID: 1da9b165b9c47f52db97fe70fe3e83626e580cdd
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 1 Telesto 2018-08-11 18:17:24 UTC
Created attachment 144113 [details]
Example file
Comment 2 Jean-Baptiste Faure 2018-08-13 05:05:05 UTC
What do you mean with "Long CPU bump"? How long.
With all version I tested, it is longer in this case (but not very long from my point of view), probably linked to the size of the last list item.

Status set to NEEDINFO, please set it back to UNCONFIRMED once requested
informations are provided.

Best regards. JBF
Comment 3 Telesto 2018-08-13 08:00:34 UTC
Created attachment 144138 [details]
Screenshot

30 seconds of hammering

Slightly tweaking the STR (which makes it far more reproducible)
1. Open the attached file (automatic spell check enabled)
2. Press Enter after Peu (on the last page) to add a new bullet
3. Select All (CTRL+A)
4. Change the language from English to French (France) 

I expect the same behavior as without step 2

also found in
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL
Comment 4 Buovjaga 2018-09-07 16:49:34 UTC
It appears we are both running into some profile b0rkenness: I was able to repro on Linux. Then I tried on Win, but nope. Then --safe-mode on Linux and no repro.
So plz test with safe mode and hopefully we can close.
Comment 5 Telesto 2018-09-07 21:03:57 UTC
Comment 1 isn't properly reproducible (see comment 3; didn't add it to the title, sorry). Again with some additions:

1. Open the attached file (automatic spell check enabled)
2. Press Enter after Peu (on the last page) to add a new bullet
3. Select All (CTRL+A)
4. Change the language from English to French (France) (bump) (wait until done)
5. Delete the new created bullet (press backspace until back to peu)
6. Press Enter again (again a long bump)

Repro with
Version: 6.2.0.0.alpha0+
Build ID: 5e8fd488f17fe0433cc9b31ace6527fb06ea3bb0
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-09-05_02:20:05
Locale: en-US (nl_NL); Calc: CL

-> in safe-mode

but not in
Versie 4.0.0.3 (Bouw-id: 7545bee9c2a0782548772a21bc84a9dcc583b89
Comment 6 Buovjaga 2018-09-10 18:54:05 UTC
So you are saying all of those bumps in the previous comment are about 30 seconds long? Because I'm not seeing them. They are short bumps.

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 033a68c49fe2b8aa397832d92d400eb0259ea809
CPU threads: 8; OS: Linux 4.18; UI render: default; VCL: gtk3_kde5; 
Locale: fi-FI (fi_FI.UTF-8); Calc: threaded
Built on September 5th 2018
Comment 7 Telesto 2018-09-10 19:36:25 UTC
(In reply to Buovjaga from comment #6)
> So you are saying all of those bumps in the previous comment are about 30
> seconds long? Because I'm not seeing them. They are short bumps.
> 
> Arch Linux 64-bit
> Version: 6.2.0.0.alpha0+
> Build ID: 033a68c49fe2b8aa397832d92d400eb0259ea809
> CPU threads: 8; OS: Linux 4.18; UI render: default; VCL: gtk3_kde5; 
> Locale: fi-FI (fi_FI.UTF-8); Calc: threaded
> Built on September 5th 2018

The length of the bumps differ.. 4 & 6 are the longest. 10-15 seconds. I will create a screencast.
Comment 8 Chen yu an 2018-11-29 09:07:03 UTC
Bug not reproducible in version
It only use 5 second

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 0f25a3c36f27fd51453b9a9115f236b83c143684
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-27_20:06:55
Locale: zh-TW (zh_TW); UI-Language: en-US
Calc: threaded
Comment 9 Telesto 2018-11-29 13:39:31 UTC
No repro either:
Version: 6.3.0.0.alpha0+
Build ID: f21d2b48bd68424a96aa6cd5572e368208378291
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-11-27_00:26:54
Locale: en-US (nl_NL); UI-Language: en-US
Calc: CL