Bug Hunting Session
Bug 119247 - Base crashes if a form based on a query with replaceable parameters, with parameter dialog open, is closed and the dialog box still open: Crash in: libgobject-2.0.so.0.5600.1
Summary: Base crashes if a form based on a query with replaceable parameters, with par...
Status: RESOLVED DUPLICATE of bug 119245
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-13 12:17 UTC by Drew Jensen
Modified: 2018-08-15 09:47 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["libgobject-2.0.so.0.5600.1"]


Attachments
example database file (128.48 KB, application/vnd.oasis.opendocument.database)
2018-08-13 12:17 UTC, Drew Jensen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Drew Jensen 2018-08-13 12:17:06 UTC
Created attachment 144144 [details]
example database file

All test on Ubuntu 18.04 (64 bit)
This bug was filed from the crash reporting server and is 

Libo 6.0.5
e7db096f-9a19-48b0-8104-4550489fbc09

Libo 6.1
br-ac74be47-0638-4925-8c50-79fbfd00ef76.


Libo 6.2
5bbcf104-c57c-4f33-be3f-37bb86f0c839
=========================================

To reproduce:
1. open the the attached file:
2. open the first form 'Lookup_By_Name'
3. Close the form.

if this is 6.0.5 or 6.2 this will crash Libreoffice, it becomes non-responsive, when the dialog box closed, if this is 6.1 RC3 the dialog box becomes non-responsive before it is closed.
Comment 1 Robert Großkopf 2018-08-14 06:52:35 UTC
Tried this one.
Opened the form and input values for firstname and lastname.
Pressed OK.
Error appears because values couldn't be found for listfields.
Opened the form for editing:
Listfield "Practitioner" and "Insurance" are bounded to field '1', but there is only one field and counting begins with '0'. So I set both listfields to '0'.
Opened the form again for input data - works as expected.

Then opened the form. The dialog for input names appears. Closing the form with ignoring the dialog and then closing the dialog leads to a crash.

Expected behavior: The dialog should be automatically closed when the form will be closed.

So I could confirm the buggy behavior with
Version: 6.1.0.3
Build-ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU-Threads: 6; BS: Linux 4.12; UI-Render: Standard; VCL: kde4; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group threaded

(OpenSUSE 15.0 64bit rpm Linux)
Comment 2 Xisco Faulí 2018-08-14 12:24:30 UTC
This is only Linux! On windows, the report can't be closed if the Parameter Input dialog is not closed... Also reproduced with gen or gtk...
Comment 3 Xisco Faulí 2018-08-14 12:28:41 UTC
This is another child dialog closed after parent crash...

@Caolán, I thought you could be interested in this one...
Comment 4 Caolán McNamara 2018-08-14 15:30:28 UTC
fix for bug#119245 fixes this too

*** This bug has been marked as a duplicate of bug 119245 ***
Comment 5 Drew Jensen 2018-08-14 16:52:37 UTC
(In reply to Caolán McNamara from comment #4)
> fix for bug#119245 fixes this too
> 
> *** This bug has been marked as a duplicate of bug 119245 ***

Isn't the problem here first that the dialog is non-modal under Linux, so the user can dismiss the form with the dialog still open, and second it causes the application to become non-response. This happens in 6.0.5 release when the dialog box still opened on top of the form. 

So, I won't set it back to new but will see if that fix just submitted also makes it modal again and if not will come back to this.
Comment 6 Xisco Faulí 2018-08-15 09:47:25 UTC
Indeed, it's no longer reproduced after the fix for bug 119245.

Tested in

Version: 6.2.0.0.alpha0+
Build ID: 18e20676024baecaf5719139f80f053f5f1e784a
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded