Bug 119254 - Pasting a slide with multiple shapes (~1000) takes longer with GTK3 backend
Summary: Pasting a slide with multiple shapes (~1000) takes longer with GTK3 backend
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks: gtk3-whipping-boy
  Show dependency treegraph
 
Reported: 2018-08-13 15:32 UTC by Gorka Navarrete
Modified: 2018-12-12 14:49 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Presentation with a slide with 2000 shapes (27.12 MB, application/vnd.oasis.opendocument.presentation)
2018-08-13 15:32 UTC, Gorka Navarrete
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gorka Navarrete 2018-08-13 15:32:56 UTC
Created attachment 144153 [details]
Presentation with a slide with 2000 shapes

When copy/pasting a slide with multiple shapes in Ubuntu, the UI freezes for a long time.

I attach a file with an empty slide and a second slice that contains > 2000 shapes (1000 triangles and 1000 circles). If I copy/paste slide 2, the UI freezes for a long time. For more complex documents, the time increases considerably.

LO 6.0.6.2: 1m 52s
LO 6.1.0.3: 1m 18s

Also, if I dare to try to select and copy all the shapes in the slide, the whole computer freezes and becomes unusable.

I believe that a similar document was handled significantly better in LO a few years back (~2013).

If I do the same operation in a VM with Windows 7 and Microsoft Office 2013 (.odp, .ppt or .pptx), the copy/paste or selection is almost instantaneous. Interestingly, when I save in LO the .odp file in .ppt/pptx, the 29MB file becomes a 1MB file.
Comment 1 Roman Kuznetsov 2018-08-13 19:32:38 UTC
1. I opened attach file in LO 6.1.0.3 on Windows 10 and tried copy/paste slide with many shapes. I have about 3-4 sec for paste new slide!

don't confirm long time paste of slide on >>>Windows 10<<<.

2. Really, if save ODP to PPTX, then size of file will be VERY small (about 1 mb)! And this PPTX opens fine in LO, it has all shapes and photo of man in right-bottom corner of slide.
Comment 2 MM 2018-08-13 20:52:02 UTC
I'm not getting the slow times as the reporter, but they are slower than in previous versions.

On ubuntu 16.04 x64 with Version: 6.2.0.0.alpha0+
Build ID: 4f50129e54c8b4a78e35dc869fd1f5fbc5aa9a87
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-08-04_22:32:09
Locale: en-US (en_US.UTF-8); Calc: threaded

they are about 8-10 secs and undo something similar.

With Version: 5.3.7.2
Build ID: 6b8ed514a9f8b44d37a1b96673cbbdd077e24059
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; VCL: gtk2; Layout Engine: new; 
Locale: en-US (en_US.UTF-8); Calc: single

pasting takes about 3-4 secs and undo-ing is < a second.
Comment 3 Telesto 2018-08-14 07:19:24 UTC
@ Gorka Navarrete 
Which version of Ubuntu & Libo downloaded from libreoffice.org or Ubuntu repro?
Comment 4 Gorka Navarrete 2018-08-14 12:53:54 UTC
@Telesto, The times I reported are from a 2 years old Ubuntu 16.04 HP workstation (Xeon proc, 16GB, SSD HD) in a Downloaded (from the web) LO 6.1.0.3 and 6.0.6.2 from the LO PPA: https://launchpad.net/~libreoffice/+archive/ubuntu/ppa

But this also happens in a i7-5600U 8GB SSD Lenovo laptop with ubuntu 18.04 using LO 6.0.3.2 from the Ubuntu repos, and in a third desktop i7 8GB SSD computer.

A part of the problem seems to be related with GTK3. Using sudo apt remove libreoffice-gtk* makes the time go down to less than 5 seconds in my laptop (from ~2 minutes).
Comment 5 Roman Kuznetsov 2018-08-14 13:12:53 UTC
Caolan, may be you are interesting in this problem?
Comment 6 Buovjaga 2018-09-07 17:15:46 UTC
Yep, gtk3 takes 8 secs for me while gen and gtk2 take a bit over 3 secs.

No idea where those 1 min+ times are coming from. Gorka: you should do a separate test by launching in safe mode, from terminal with 'libreoffice --safe-mode' or Help - Restart in safe mode and then Continue in safe mode.

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 033a68c49fe2b8aa397832d92d400eb0259ea809
CPU threads: 8; OS: Linux 4.18; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); Calc: threaded
Built on September 5th 2018
Comment 7 Caolán McNamara 2018-09-07 19:03:28 UTC
it may not be gtk3 vs non-gtk3, it may be a11y enabled libreoffice vs a11y disabled one
Comment 8 Gorka Navarrete 2018-09-07 20:54:44 UTC
Buovjaga, I tried starting from a terminal with libreoffice --safe-mode and times are still >1m.

With a i7-4790 (8GB RAM), Ubuntu 18.04, LO 6.0.3.2:

safe mode: ~1m40s
normal mode: ~1m37s
NO gtk3 (a11y disabled): ~2s