Bug 119299 - UI: Layout shifting a little when opening the Color dialog in Table properties Background
Summary: UI: Layout shifting a little when opening the Color dialog in Table propertie...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: lowest trivial
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:6.2.0
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-15 14:25 UTC by Telesto
Modified: 2018-09-18 14:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sceencast (1.09 MB, video/quicktime)
2018-08-15 17:00 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-08-15 14:25:54 UTC
Description:
UI: Layout shifting a little when opening the Color dialog in Table properties Background 

Steps to Reproduce:
1. Open Writer
2. Insert a table
3. Open the Table Properties dialog
4. Background tab -> Press color button. The color picker resizes 

Actual Results:
Layout shifting a little

Expected Results:
Stable layout


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.0.0.alpha0+
Build ID: c958f52b813d34baa9b5236bb34a08a04e6b0aba
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2018-08-10_05:06:44
Locale: nl-NL (nl_NL.UTF-8); Calc: threaded
Comment 1 Xisco Faulí 2018-08-15 16:41:10 UTC
I can't reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: 1af7f19224f18e5025352339648db659575eae33
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

Could you please create and attach a screencast showing the problem ?
Comment 2 Telesto 2018-08-15 17:00:46 UTC
Created attachment 144204 [details]
Sceencast
Comment 3 Xisco Faulí 2018-08-15 18:35:16 UTC
this was recently reworked by Jim in https://cgit.freedesktop.org/libreoffice/core/commit/?id=41f1a38b9e8b5e0567bf642d3e14a549e82ee0d9

Adding him to the loop...

IMHO, if it takes more than 5 minutes to fix it, RESOLVED WONTFIX...
Comment 4 Jim Raykowski 2018-08-16 06:05:07 UTC
I confirm with Linux:

Version: 6.2.0.0.alpha0+
Build ID: d0425778eef7ea20ccc19834c07d0b265f58baf0
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group threaded

but NOT with Windows:

Version: 6.0.2.1 (x64)
Build ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
CPU threads: 4; OS: Windows 10.0; UI render: default;
Locale: en-US (en_US); Calc: group

The rework of the Background/Highlight tab page derives from the Area tab page. If it happens in the Area tab page it will be inherited by the reworked Background/Highlight tab page. In this case it happens in the Area tab page of the Paragraph dialog. It also happens in the Format > Character Dialog Highlighting tab. I noticed if freecolour-hlc is choosen as the pallette this does not occur. Seems that how the layout rendering is done for Linux may be causing this?
Comment 5 Telesto 2018-08-16 14:31:24 UTC
The cause seems to be they freecolour-hlc scroll bar. Dialag is probably adjusted  dynamically.

Switch from None to Color with free-colour-hlc is selected, adjusts the selection window considering the layout making with scrollbar; making the color picker items smaller. A little to small with the free-colour hlc selected (in my opinion)
Comment 6 Maxim Monastirsky 2018-08-16 15:40:50 UTC
https://gerrit.libreoffice.org/59206/

I think this should stop the layout shifting. Testing is much appreciated.
Comment 7 Jim Raykowski 2018-08-16 18:45:31 UTC
(In reply to Maxim Monastirsky from comment #6)
> https://gerrit.libreoffice.org/59206/
> 
> I think this should stop the layout shifting. Testing is much appreciated.

Tested with:
 
Version: 6.2.0.0.alpha0+
Build ID: d0425778eef7ea20ccc19834c07d0b265f58baf0
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group threaded

Doesn't shift when patch is applied.
Comment 8 Commit Notification 2018-08-17 05:16:14 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=da7040510d5be27ad7b90ffb0c962535f3375358

tdf#119299 Start with a never scrollbar policy

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 BogdanB 2018-09-18 14:54:29 UTC
Working ok on Version: 6.2.0.0.alpha0+
Build ID: e005ab5d40d358adb75a64e140d46f4bf605647d
CPU threads: 4; OS: Linux 4.15; UI render: GL; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-09-15_02:08:38
Locale: ro-RO (ro_RO.UTF-8); Calc: threaded