Bug Hunting Session
Bug 119311 - Area tab: Pattern preview displayed on bitmap preview
Summary: Area tab: Pattern preview displayed on bitmap preview
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Paragraph-Dialog
  Show dependency treegraph
 
Reported: 2018-08-16 09:24 UTC by Xisco Faulí
Modified: 2019-09-02 09:23 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-08-16 09:24:52 UTC
Steps to reproduce:

1) Menu > Format > Paragraph
Paragraph dialog opens
2) Area tab
3) Pattern button
4) Select any pattern
5) Select OK
Paragraph dialog closes and paragraph is pattern filled
6) Menu > Format > Paragraph
7) Click on Bitmap

-> Pattern preview is displayed instead of bitmap preview..

Reproduced in

Version: 6.2.0.0.alpha0+
Build ID: 1af7f19224f18e5025352339648db659575eae33
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded
Comment 1 Xisco Faulí 2018-08-16 09:27:40 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=63961b9b45c95999dcc6b5ab080035609068ff69

author	Katarina Behrens <Katarina.Behrens@cib.de>	2017-03-05 22:56:36 +0100
committer	Katarina Behrens <Katarina.Behrens@cib.de>	2017-03-06 13:18:15 +0000
commit	63961b9b45c95999dcc6b5ab080035609068ff69 (patch)
tree	a76f779d94c6ed0a8c0ce5926deb46301b255942
parent	38fd98a0513638634868132e9c922366bcc8c622 (diff)
tdf#103847: Pass also XFillStyleItem to subtabs
this resolves the issue of non-preset gradient and hatch values not
being shown. Bitmap is still broken (beyond repair)

Bisected with: bibisect-linux-64-5.4

Adding Cc: to Katarina Behrens
Comment 2 Julien Nabet 2018-08-19 12:06:47 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.

Reverting locally https://cgit.freedesktop.org/libreoffice/core/commit/?id=63961b9b45c95999dcc6b5ab080035609068ff69 doesn't help.
Comment 3 Jim Raykowski 2018-08-22 22:20:14 UTC
patch submitted for bug 111718 seems to patch this bug also:
https://gerrit.libreoffice.org/#/c/58805/

Testing is very much appreciated.
Comment 4 QA Administrators 2019-09-02 09:19:53 UTC Comment hidden (obsolete)
Comment 5 Xisco Faulí 2019-09-02 09:23:36 UTC
No longer reproducible in

Version: 6.4.0.0.alpha0+
Build ID: 41cd3e8e817c8c33a13608e62eeb06ce2c6977e4
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Likely a duplicate of bug 111718.
Closing as RESOLVED WORKSFORME anyway..