Bug Hunting Session
Bug 119317 - FORMATTING in TABLE: wrong color names in background palette
Summary: FORMATTING in TABLE: wrong color names in background palette
Status: RESOLVED DUPLICATE of bug 119325
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Table-Properties-Dialog
  Show dependency treegraph
 
Reported: 2018-08-16 17:04 UTC by Joop Lanting
Modified: 2018-08-20 12:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joop Lanting 2018-08-16 17:04:41 UTC
Hovering a color cell shows a wrong name, e.g. medium gray lists 'blue9'.
;JOOP!
Comment 1 Dieter Praas 2018-08-16 17:25:32 UTC
I confirm it with

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 0a1a4ffb4f87adff7fbbbc60202b6a0e42fedd0c
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-08-08_23:17:46
Locale: en-US (de_DE); Calc: CL

It seems to me, that only the first row shows color names (pallette: standard). They are all wrong.
Comment 2 Xisco Faulí 2018-08-17 07:10:07 UTC
Testing this issue I found bug 119325, so I don't know whether it's possible to reproduce it on master right now...

Reproduced in

Versión: 6.1.0.3
Id. de compilación: efb621ed25068d70781dc026f7e9c5187a4decd1
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threaded
Comment 3 Regina Henschel 2018-08-17 12:05:16 UTC
The error exists in master too, tested with Version: 6.2.0.0.alpha0+ (x64)
Build ID: 76532719505a3d9b495911ce7f86b8cda8412a00
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
Locale: en-US (en_US); Calc: CL

Not only this special dialog is wrong, but others too. Only the "Color Bar" seems to be OK.

The tooltips are shifted. For example in palette "html" the color "Orchid" should be in column 6|row 11. But I get that name for an area from column 3½ to 4½ | row 1½ to 2½. So perhaps in bug 119325 you see no tooltips because the palette does not have a color at that position. You should try it again with a larger palette.
Comment 4 Julien Nabet 2018-08-19 11:58:26 UTC
(In reply to Regina Henschel from comment #3)
>...
> The tooltips are shifted. For example in palette "html" the color "Orchid"
> should be in column 6|row 11. But I get that name for an area from column 3½
> to 4½ | row 1½ to 2½. So perhaps in bug 119325 you see no tooltips because
> the palette does not have a color at that position. You should try it again
> with a larger palette.

76532719505a3d9b495911ce7f86b8cda8412a00 is before the Caolán's patch https://cgit.freedesktop.org/libreoffice/core/commit/?id=0994fcef4b401ff7a99a9e8e882f6e2697d310c7
On pc Debian x86-64 with master sources updated today, column 6|row 11 in html palette corresponds indeed to "orchid".
IMHO, it should be dup but perhaps I missed something.
Comment 5 Xisco Faulí 2018-08-20 11:44:45 UTC
I can no longer reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: 401cba4c20fbc930f034168872642428d7459218
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

@Joop, @Regina, could you please try again with a recent master build ?
Comment 6 Regina Henschel 2018-08-20 12:09:57 UTC
No error in Version: 6.2.0.0.alpha0+ (x64)
Build-ID: c3554e77056b6c950fe946c7c53dd93838e17c9a
CPU-Threads: 8; BS: Windows 10.0; UI-Render: GL; 
Gebietsschema: de-DE (en_US); Calc: threaded

I would say, this bug is duplicate to bug 119325.
Comment 7 Xisco Faulí 2018-08-20 12:14:00 UTC

*** This bug has been marked as a duplicate of bug 119325 ***