Download it now!
Bug 119328 - LibreOffice is called "Unknown Application Name" on Unity 7
Summary: LibreOffice is called "Unknown Application Name" on Unity 7
Status: RESOLVED DUPLICATE of bug 119881
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-17 11:16 UTC by Ettore Atalan
Modified: 2018-10-04 05:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing the problem. (153.60 KB, image/png)
2018-08-17 11:16 UTC, Ettore Atalan
Details
LibreOffice under Unity 7 with fixed menu (95.14 KB, image/png)
2018-09-12 16:44 UTC, markus.neumeister
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ettore Atalan 2018-08-17 11:16:08 UTC
Description:
Hi

The name of LibreOffice within the menu bar of Ubuntu's Unity 7 Desktop is "Unknown Application Name" since quite a while.

Regards,
Atalanttore

Steps to Reproduce:
1. Open LibreOffice on Ubuntu with Unity 7 Desktop.
2. Check the name within the menu bar.

Actual Results:
LibreOffice is called "Unknown Application Name".

Expected Results:
The name "LibreOffice".


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Ettore Atalan 2018-08-17 11:16:43 UTC
Created attachment 144249 [details]
Screenshot showing the problem.
Comment 2 Timur 2018-08-17 15:08:55 UTC Comment hidden (obsolete)
Comment 3 Ettore Atalan 2018-08-17 19:18:55 UTC
Reported to Ubuntu: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1787642
Comment 4 mondane.woodworker 2018-09-01 07:57:38 UTC
Based on this comment, the bug is in LO: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1589215/comments/23

Could this be fixed?

A more precise issue:
Comment 5 markus.neumeister 2018-09-12 16:39:39 UTC
I can confirm this issue on Ubuntu with Unity 7. You can fix it manually by adding ‘env XDG_CURRENT_DESKTOP=Unity’ to every 'Exec=' line in the .desktop files, so it's probably a LO issue.

There is also a discussion in the Unity Development thread on community.ubuntu.com:

https://discourse.ubuntu.com/t/testing-unity-session-in-18-04/987/257

See also Khurshids comment here:

https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1589215/comments/25
Comment 6 markus.neumeister 2018-09-12 16:44:05 UTC
Created attachment 144820 [details]
LibreOffice under Unity 7 with fixed menu

Here is a screenshot of LO 6.0.6.2 under Ubuntu 18.04 with Unity 7 and the applied 'env XDG_CURRENT_DESKTOP=Unity' workaround. As you can see, the 'Unknown Application Name' is gone and the Gnome App Menu also don't get loaded under Unity as it should be.
Comment 7 Xisco Faulí 2018-09-14 10:56:15 UTC
Searching in the internet, I found the XDG_CURRENT_DESKTOP has changed from Unity to Unity:Unity7:ubuntu. I'm wordering if https://gerrit.libreoffice.org/#/c/60489/ would fix it...
Anyone with Unity7 could try it ?
Comment 8 markus.neumeister 2018-09-14 11:08:14 UTC
(In reply to Xisco Faulí from comment #7)
> Anyone with Unity7 could try it ?

I can test it, if you tell me how.
Comment 9 Xisco Faulí 2018-09-14 15:08:59 UTC
Let's close this as a dupe of bug 119881, which is the way to fix this, by iterating over the colons...

*** This bug has been marked as a duplicate of bug 119881 ***