Bug 119329 - Variable in equation in .docx vanishes if we open the file in Writer (Win10 only?)
Summary: Variable in equation in .docx vanishes if we open the file in Writer (Win10 o...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) release
Hardware: All Windows (All)
: low normal
Assignee: Not Assigned
Keywords: filter:docx, notBibisectable, regression
Depends on:
Blocks: DOCX-Formula
  Show dependency treegraph
Reported: 2018-08-17 15:12 UTC by Marco A.G.Pinto
Modified: 2022-10-20 03:43 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:

Equation where the constant vanishes (21.29 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-08-17 15:12 UTC, Marco A.G.Pinto
formula in 6.1.1 (23.39 KB, image/png)
2018-08-17 19:52 UTC, BogdanB
Screenshot LO 6.2 alpha 0 VS Word 365 (117.54 KB, image/png)
2018-08-24 12:25 UTC, Marco A.G.Pinto
Euler's number doesn't appear on equation (another example) (17.40 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-09-28 06:00 UTC, Marco A.G.Pinto
First DOCX compared in MSO and LO (192.38 KB, image/png)
2019-10-23 12:27 UTC, Timur
Second DOCX compared in MSO and LO (101.04 KB, image/png)
2019-10-23 12:29 UTC, Timur
Word 365 (66.47 KB, image/png)
2019-10-23 14:44 UTC, Marco A.G.Pinto
LO 6.3.2 (65.33 KB, image/png)
2019-10-23 14:45 UTC, Marco A.G.Pinto

Note You need to log in before you can comment on or make changes to this bug.
Description Marco A.G.Pinto 2018-08-17 15:12:53 UTC
Created attachment 144253 [details]
Equation where the constant vanishes

The constant below the divisor vanishes in Writer.

See the attachment sample.
Comment 1 BogdanB 2018-08-17 19:51:35 UTC
This is how Writer open it in 6.1.1. See the screenshot.

Build ID: 5a56b72413d5f555c854e36d3bd2fd50ec21644c
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-6-1, Time: 2018-08-15_02:45:13
Locale: ro-RO (ro_RO.UTF-8); Calc: group threaded
Comment 2 BogdanB 2018-08-17 19:52:08 UTC
Created attachment 144258 [details]
formula in 6.1.1
Comment 3 BogdanB 2018-08-17 19:53:05 UTC
It's ok like this, or should be even different?
Comment 4 Marco A.G.Pinto 2018-08-17 19:59:53 UTC
Ahhhh.. 6.1.1 seems to fix the bug!

Thank you!
Comment 5 Julien Nabet 2018-08-18 20:21:00 UTC
So let's put this one to WFM then.
Comment 6 Marco A.G.Pinto 2018-08-23 13:06:30 UTC

While discussing this issue on IRC we noticed that the equations in Word 365 use the font "Cambria Math", while LO converts them to "Liberation Serif".

In LO 6.2 alpha 0, I double-clicked in the equation and in the editor changed the font to the original and the "e" appeared.

Can LO be improved to try to keep the original font in .docx equations?

Thank you!
Comment 7 Stephan van den Akker 2018-08-23 13:30:16 UTC
Note that the "ⅇ" in attachment 144253 [details] is not a simple ASCII "e", but a "DOUBLE-STRUCK ITALIC SMALL E" (U+2147). 

Can't reproduce this problem in:

Build ID: c658fd4609c05617c785870b00aa3a0998375cc6
CPU-threads: 4; Besturingssysteem: Linux 4.12; UI-render: standaard; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); Calc: threaded


Build ID: 00m0(Build:2)
CPU threads: 4; OS: Linux 4.12; UI render: default; VCL: kde4; 
Locale: en-GB (en_GB.UTF-8); Calc: group

My test system doesn't have Cambria Math installed, so I presume LO is forced to substitute it with Liberation Sans. Still the ⅇ in attachment 144253 [details] is rendered OK.
Comment 8 Marco A.G.Pinto 2018-08-23 13:44:50 UTC
It is a mathematical letter:
"Euler's number"

I hope this helps.
Comment 9 Aron Budea 2018-08-23 15:34:32 UTC
"e" is shown fine for me in LO & 6.2 daily build (2018-08-17_00:41:06, 380d0fda99ff664de8443cfc33c7c86bca18134c) / Windows7, both with and without OpenGL.
Note that I tested this on a computer where Office is also installed.
Comment 10 himajin100000 2018-08-24 05:53:11 UTC
Though I know even Word 2016 itself insists in its context menu that the 'e' character is U+2147 ,the displayed 'e' does not look "Double-Struck"
Comment 11 Timur 2018-08-24 12:06:07 UTC
This bug was changed to WORKSFORME based on multiple conformations that original issue is not present. Even though we didn't have conformation that it was really wrong. 
Marco, please don't change status asking than for something else. Especially if you're not familiar with statuses because REOPENED is for fix not working and that cannot be case here. 

As for equation font, I can see it's "Cambria Math" in MSO, while I don't see that LO converts them to "Liberation Serif". Please explain or attach screenshot how you saw it.
Comment 12 Marco A.G.Pinto 2018-08-24 12:25:05 UTC
Created attachment 144409 [details]
Screenshot LO 6.2 alpha 0 VS Word 365

Here are the screenshots!
Comment 13 Timur 2018-08-24 13:57:41 UTC
What you show is Formula-Fonts. But I guess it's setting, not reading. 
Look that you see real font "Times New Roman" same as other text. Not sure if it's correct. 
See also Bug 116749. Not so simple.
Comment 14 Marco A.G.Pinto 2018-08-24 14:08:36 UTC
(In reply to Timur from comment #13)
> What you show is Formula-Fonts. But I guess it's setting, not reading. 
> Look that you see real font "Times New Roman" same as other text. Not sure
> if it's correct. 
> See also Bug 116749. Not so simple.

If you place the edit cursor inside the formula in Word 365 it will show "Cambria Math" (see the screenshot: I placed a red square on the places).

I am writing my thesis with Times New Roman, but every time I insert an equation, Word uses "Cambria Math" in them.
Comment 15 Timur 2018-08-27 09:53:15 UTC
I understand. Looks like it's Bug 116749.
Comment 16 Aron Budea 2018-09-06 20:53:22 UTC
Marco wrote the bug is still there with a daily build from yesterday, even with safe mode. Returning status to UNCONFIRMED.
Comment 17 Marco A.G.Pinto 2018-09-06 21:59:51 UTC
I don't know if this helps, but after a double-click in the equation, we get to the editor and I just copied the "e" from there in the formula, then pressed <ESC> and pasted the clipboard in the document body and the "e" appears in the document, but not inside the equation.

Maybe this can narrow the issue to the equation itself.
Comment 18 Marco A.G.Pinto 2018-09-28 06:00:58 UTC
Created attachment 145239 [details]
Euler's number doesn't appear on equation (another example)
Comment 19 Marco A.G.Pinto 2018-09-28 06:02:56 UTC
Here is another example (see screenshot)

If we have the "e" as plaintext, it appears.

If we have the "e" in an equation, we get a blank character.
Comment 20 Buovjaga 2018-10-01 17:59:15 UTC
(In reply to Marco A.G.Pinto from comment #18)
> Created attachment 145239 [details]
> Euler's number doesn't appear on equation (another example)

I confirm with this and the original document on Windows from master down to version 5.4.2. Version 5.3.0 does not show the problem.
*None* of the bibisect repos show the problem, which is puzzling!

Not seen on Linux.
Comment 21 Timur 2019-10-23 12:27:39 UTC
Created attachment 155257 [details]
First DOCX compared in MSO and LO

I don't see an issue.
Comment 22 Timur 2019-10-23 12:29:29 UTC
Created attachment 155258 [details]
Second DOCX compared in MSO and LO

Also on 2nd DOCX I don't see an issue with Euler. 
Please explain what this bug is about. 
Note: image is blurred, that another bug.
Comment 23 Marco A.G.Pinto 2019-10-23 13:08:03 UTC
With my two examples above I still get a blank "e" with LO 6.3.2.

Have you tested the files with Windows 10 1903?
Comment 24 Timur 2019-10-23 14:21:48 UTC
Marco, please make a screenshot where issue can be seen, do not edit and cover formula like attachment 144409 [details].
Please see if you can test on some other system. 
This is not a simple bug, always reproducible. I showed that's not on my Win7 or Linux. 
No point in bug staying open for the sake of bug, unless we know exactly when it happens.
Comment 25 Marco A.G.Pinto 2019-10-23 14:44:43 UTC
Created attachment 155262 [details]
Word 365

Word 365
Comment 26 Marco A.G.Pinto 2019-10-23 14:45:16 UTC
Created attachment 155263 [details]
LO 6.3.2
Comment 27 Marco A.G.Pinto 2019-10-23 14:45:51 UTC
Here are the screenshots, both on Word 365 and on LO 6.3.2.
Comment 28 Buovjaga 2019-10-23 15:12:33 UTC
(In reply to Marco A.G.Pinto from comment #26)
> Created attachment 155263 [details]
> LO 6.3.2

I get the same result

Version: (x64)
Build ID: 7c6226bee72805db7f0e567ca9f06c786a7d0da2
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded
Comment 29 Timur 2019-10-23 16:34:29 UTC
It should be clear when this happens, what are the prerequisites. So far it seems Windows 10 only, so I updated the title. But it may not be correct, could be some font issue, please try to find out, I don't repro in Windows 7.
Comment 30 Timur 2020-10-19 12:19:30 UTC
Marco, please retest, Buovjaga please do bibisect or remove keyword.
Comment 31 Buovjaga 2020-10-19 12:29:35 UTC
Still confirmed

Version: (x64)
Build ID: df74aef7159d7155addf78cfc4d139485945d794
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: default; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded
Comment 32 QA Administrators 2022-10-20 03:43:35 UTC
Dear Marco A.G.Pinto,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword

Feel free to come ask questions or to say hello in our QA chat: https://web.libera.chat/?settings=#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team