Bug 119335 - When handling a document with multiple tables Libre-Office Writer freezes and crashes
Summary: When handling a document with multiple tables Libre-Office Writer freezes and...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.6.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Cell-Management
  Show dependency treegraph
 
Reported: 2018-08-17 20:12 UTC by Hugh Davie
Modified: 2018-10-15 23:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hugh Davie 2018-08-17 20:12:59 UTC
Description:
Document with 6 tables
Try to resize table width and column width
Writer repeatedly freezes
sometimes say repaginating
finally crashes.
Version 
Version: 6.0.6.2 (x64)
Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: en-GB (en_GB); Calc: group

Steps to Reproduce:
1. Create document with multiple tables
2. try re-sizing tables
3. try resizing columns

Actual Results:
freezes and crashes

Expected Results:
table resizes quickly


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Dieter 2018-08-18 07:41:52 UTC
Can't reproduce it with

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 0a1a4ffb4f87adff7fbbbc60202b6a0e42fedd0c
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-08-08_23:17:46
Locale: en-US (de_DE); Calc: CL


Do you get a crash report?
Comment 2 Roman Kuznetsov 2018-08-18 08:21:32 UTC
don't repro in

Версия: 6.1.0.3 (x64)
ID сборки: efb621ed25068d70781dc026f7e9c5187a4decd1
Потоков ЦП: 4; ОС:Windows 10.0; Отрисовка ИП: по умолчанию; 
Локаль: ru-RU (ru_RU); Calc: CL

1. Please try delete your user profile and check problem
and
2. Please update your LibreOffice to version 6.0.6 and check problem
Comment 3 raal 2018-08-18 11:00:21 UTC
Hello,

Thank you for filing the bug. For the test, could you rename your LibreOffice directory profile (see https://wiki.documentfoundation.org/UserProfile) and give it a new try? Thank you

no repro withVersion: 6.2.0.0.alpha0+ (x64)
Build ID: 215780a7eca23c1bfcde74958e10ae84ea12d506
CPU threads: 1; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-08-15_22:56:00
Comment 4 Hugh Davie 2018-08-18 11:26:35 UTC
Sorry no crash report as just froze and then in the end I just closed Writer.
Tried again in Safe Mode and fault does not reproduce.
So have followed suggestion in comment 2 and rolled the user profile back to earlier example and installed latest version.
Will report back if error re-occurs but at present it is all running a lot faster and not freezing when re-sizing columns of tables.
Comment 5 Dieter 2018-08-18 12:47:14 UTC
(In reply to Hugh Davie from comment #4)
> Will report back if error re-occurs but at present it is all running a lot
> faster and not freezing when re-sizing columns of tables.

So I tink, we can close this bug report as WORFSFORME. Please change it back to UNCONIRMED if it happens again.