Download it now!
Bug 119344 - Build from sources with boost 1.68.0 fails, because libcmis 0.5.1 requires boost/uuid/sha1.hpp
Summary: Build from sources with boost 1.68.0 fails, because libcmis 0.5.1 requires bo...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0 target:6.1.2
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-18 13:04 UTC by Artem Kurashov
Modified: 2018-10-08 12:11 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Artem Kurashov 2018-08-18 13:04:59 UTC
The third-party libraries of LibreOffice 6.1.0.3 include the library libcmis 0.5.1, which requires boost/uuid/sha1.hpp file from boost library. However, boost/uuid/sha1.hpp file within boost 1.68.0 was moved to boost/uuid/detail/sha1.hpp. As a result of this, build process fails.
Comment 1 Julien Nabet 2018-08-18 15:57:37 UTC
Just for information, master sources use:
- libcmis-0.5.1
- boost 1.66

See https://wiki.documentfoundation.org/Development/BuildingOnLinux for information about building on Linux.

David: thought you might be interested in this one since it concerns libcmis.
Comment 2 rezso 2018-09-03 23:31:32 UTC
Please try this:
https://gerrit.libreoffice.org/#/c/59958/
Comment 3 Commit Notification 2018-09-04 08:46:23 UTC
rezso committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3ef3569c4ae1c5319aff0664d52cbd8a8d42c909

tdf#119344 fix libcmis build with boost 1.68

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2018-09-04 19:38:46 UTC
rezso committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=af17b06f657257c6bfee19c1d8d1c4b632fbcc2a&h=libreoffice-6-1

tdf#119344 fix libcmis build with boost 1.68

It will be available in 6.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Buovjaga 2018-09-24 18:40:56 UTC
Artem: is this fixed for you?
Comment 6 Xavier Van Wijmeersch 2018-09-25 14:34:17 UTC
Did have the same problem with boost 1.68.0 that comes with my OS, so i compiled LO with the internal boost.
I am testing it now with a new build off LO 6.1.3 and i think the problem is gone

Best regards
Comment 7 Xavier Van Wijmeersch 2018-10-07 17:23:42 UTC
Its working for me

Version: 6.2.0.0.alpha0+
Build ID: 3250c27b86d420d4891e1f83d8b11f9999b2a7d0
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: threaded
Comment 8 Buovjaga 2018-10-08 12:11:00 UTC
Thanks, let's change to fixed.