Bug 119348 - general input/out error when i open an .odt and paste an icon ( 😆 ) TO IT
Summary: general input/out error when i open an .odt and paste an icon ( 😆 ) TO IT
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-08-18 15:58 UTC by dr.yehmy
Modified: 2019-01-02 00:32 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
4-2.COPY LINE 2 OF WEBPAGE AND PASTE,CAUSE ERROR !!GENERAL ERROR. GENERAL INPUT/ OUTPUT ERROR ! (304.13 KB, image/jpeg)
2018-08-19 10:59 UTC, dr.yehmy
Details
1.LibreOffice Writer V 5.4.3.1.-crashed (125.75 KB, image/jpeg)
2018-08-19 11:05 UTC, dr.yehmy
Details
2.RE-OPEN LibreOffice-IN-SAFE-MODE (463.29 KB, image/jpeg)
2018-08-19 11:08 UTC, dr.yehmy
Details
3.SAFE-MODE-OPTIONS- (102.36 KB, image/jpeg)
2018-08-19 11:11 UTC, dr.yehmy
Details
4.COPY LINE 2 OF WEBPAGE AND PASTE,CAUSE ERROR !! (320.52 KB, image/jpeg)
2018-08-19 11:13 UTC, dr.yehmy
Details
4-2.COPY LINE 2 OF WEBPAGE AND PASTE,CAUSE ERROR !!GENERAL ERROR. GENERAL INPUT/ OUTPUT ERROR ! (304.13 KB, image/jpeg)
2018-08-19 11:14 UTC, dr.yehmy
Details
5.MIDDLE OF WEBPAGE (401.21 KB, image/jpeg)
2018-08-19 11:15 UTC, dr.yehmy
Details
6. COPY 5.MIDDLE OF WEBPAGE AND PASTE,LIBREOFFICE WRITER CRASH . (280.97 KB, image/jpeg)
2018-08-19 11:16 UTC, dr.yehmy
Details
7.PASTE THE ICON OF INDEX FIGER IN 5.MIDDLE OF WEBPAGE CAUSE LIBREOFFICE WRITER CRASH . (302.81 KB, image/jpeg)
2018-08-19 11:18 UTC, dr.yehmy
Details
7-2.LIBREOFFICE WRITER_6.1_RECOVERY (435.20 KB, image/jpeg)
2018-08-19 11:19 UTC, dr.yehmy
Details
8.I USE WRITER 6.1.0.3 TO CREATE A NEW BLANK ODT DOCUMENT,WRITER CRASH (400.85 KB, image/jpeg)
2018-08-19 11:20 UTC, dr.yehmy
Details
8-2.WRITER RE-OPEN IN SAFE MODE (381.35 KB, image/jpeg)
2018-08-19 11:22 UTC, dr.yehmy
Details
8-3.SEND CRASH REPORT (227.54 KB, image/jpeg)
2018-08-19 11:22 UTC, dr.yehmy
Details
8-4.CRASH REPORT-RE-OPEN IN SAFE MODE (360.93 KB, image/jpeg)
2018-08-19 11:24 UTC, dr.yehmy
Details
9.OPEN WRITER 6.1.0.3 SELCT MENU_格式(O)_頁面(P)_CRASH (586.61 KB, image/jpeg)
2018-08-19 11:26 UTC, dr.yehmy
Details
9.OPEN WRITER 6.1.0.3 SELCT MENU_格式(O)_頁面(P)_CRASH-2 (453.63 KB, image/jpeg)
2018-08-19 11:27 UTC, dr.yehmy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dr.yehmy 2018-08-18 15:58:21 UTC
Description:
LibreOffice Writer  version 6.1.0.3 crash when i open an .odt and paste an icon (  😆  ) TO IT

Steps to Reproduce:
1.Use LibreOffice Writer  version 6.1.0.3 open an .odt
2.paste an icon(  😆  ) TO IT
3.LibreOffice Writer  6.1.0.3 crash

Actual Results:
LibreOffice Writer  version 6.1.0.3 crash

Expected Results:
i hope LibreOffice Writer version 6.1.0.3 provide the function so that   user can paste an icon to an .odt as they do to an email .


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Regina Henschel 2018-08-18 16:47:55 UTC
I cannot reproduce it. Do you mean an image or an Emoticon character? From where do you get it? How do you paste it? Does it happen in a new document or in an existing one? Are the values in fields "Hardware" correct or do you use a different OS? Do you have got an error message or has a crash report been generated?
Comment 2 dr.yehmy 2018-08-19 10:59:59 UTC Comment hidden (obsolete)
Comment 3 dr.yehmy 2018-08-19 11:05:18 UTC Comment hidden (obsolete)
Comment 4 dr.yehmy 2018-08-19 11:08:14 UTC Comment hidden (obsolete)
Comment 5 dr.yehmy 2018-08-19 11:11:17 UTC Comment hidden (obsolete)
Comment 6 dr.yehmy 2018-08-19 11:13:21 UTC Comment hidden (obsolete)
Comment 7 dr.yehmy 2018-08-19 11:14:47 UTC Comment hidden (obsolete)
Comment 8 dr.yehmy 2018-08-19 11:15:58 UTC Comment hidden (obsolete)
Comment 9 dr.yehmy 2018-08-19 11:16:57 UTC Comment hidden (obsolete)
Comment 10 dr.yehmy 2018-08-19 11:18:24 UTC Comment hidden (obsolete)
Comment 11 dr.yehmy 2018-08-19 11:19:38 UTC Comment hidden (obsolete)
Comment 12 dr.yehmy 2018-08-19 11:20:47 UTC Comment hidden (obsolete)
Comment 13 dr.yehmy 2018-08-19 11:22:09 UTC Comment hidden (obsolete)
Comment 14 dr.yehmy 2018-08-19 11:22:57 UTC Comment hidden (obsolete)
Comment 15 dr.yehmy 2018-08-19 11:24:05 UTC Comment hidden (obsolete)
Comment 16 dr.yehmy 2018-08-19 11:26:11 UTC Comment hidden (obsolete)
Comment 17 dr.yehmy 2018-08-19 11:27:19 UTC Comment hidden (obsolete)
Comment 18 dr.yehmy 2018-08-19 11:30:40 UTC Comment hidden (obsolete)
Comment 19 Regina Henschel 2018-08-19 12:02:20 UTC
I now get the "General Input/Output" error. But clicking on OK continues without crash.

The mentioned website is http://jillgorich.pixnet.net/blog/post/140507823-%E7%84%A1%E6%9C%AC%E7%95%B6%E6%B2%96---%E5%AD%B8%E7%BF%92%E5%BF%83%E5%BE%97%E6%91%98%E8%A6%81

The mentioned line is the line with the facebook icon. Copy from end of line above to start of line below. Paste it with default Ctrl+V.

The problematic parts are "G+" and "facebook like it". Each of them produce an "General Input/Output" error. LibreOffice generates a <draw:frame> element with a <draw:floating-frame> from it. For "G+" to https://apis.google.com/u/0/se/0/_/+1/fastbutton? with additional parameters and for "facebook like it" to http://www.facebook.com/plugins/like.php? with additional parameters.

It works without problem in Version: 6.0.6.2 (x64)
Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU threads: 8; OS: Windows 10.0; UI render: default; 
Locale: de-DE (en_US); Calc: CL
There it generates floating frames as OLE object. When you have selected such object in Navigator, you can go to menu Edit > Object > Properties to see its link.

Version: 6.1.0.3 (x64)
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 8; OS: Windows 10.0; UI render: default; 
Locale: de-DE (en_US); Calc: CL
generates the error message, but nevertheless inserts the objects, but not their content is shown, but an object placeholder.
Comment 20 Xisco Faulí 2018-08-20 18:24:59 UTC
I reproduce the crash in

Versión: 6.1.0.3
Id. de compilación: efb621ed25068d70781dc026f7e9c5187a4decd1
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threaded

while on linux I get the General Input/Output" error
Comment 21 Xisco Faulí 2018-08-20 18:36:17 UTC
The 'General Error' problem was introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=3087011e2eb810866276e270a6fc61a7e0998fec

author	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-06-07 09:44:02 +0200
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-06-13 13:40:04 +0200
commit 3087011e2eb810866276e270a6fc61a7e0998fec (patch)
tree 961c9b25d00f0258dd0c3eb4850e50b78367f7c8
parent 4a0ca73c31990568bf20a1c3f0906c3a5770a38e (diff)
Replace SVGFilter using SVGIO

Adding Cc: to Armin Le Grand

Bisected with: bibisect-linux64-6.2
Comment 22 Roman Kuznetsov 2018-12-29 09:25:45 UTC
in

Version: 6.3.0.0.alpha0+
Build ID: 49fcd3bbb30f93763fc5cb80fa6ac5cec5d00834
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-25_00:15:08
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

I can't to repro this bug

Xisco, may be already WFM?
Comment 23 Xisco Faulí 2019-01-01 17:33:34 UTC
(In reply to Xisco Faulí from comment #20)
> I reproduce the crash in
> 
> Versión: 6.1.0.3
> Id. de compilación: efb621ed25068d70781dc026f7e9c5187a4decd1
> Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
> Configuración regional: es-ES (es_ES); Calc: group threaded
> 
> while on linux I get the General Input/Output" error

So I still get the Gereral Input/Output error in

Versión: 6.2.0.1
Id. de compilación: 0412ee99e862f384c1106d0841a950c4cfaa9df1
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded

but not the crash
Comment 24 dr.yehmy 2019-01-01 20:13:23 UTC
Paste  😆  on  Writer is   OK  
in version 6.0.6.2  ,  6.0.7.3 ,  6.1.4.2  
WIN 7 PROFESSIONAL ,0X86