Bug 119363 - FORMATTING MARKS: LO should provide a way to indicate, that there is a blank space at the end of the line
Summary: FORMATTING MARKS: LO should provide a way to indicate, that there is a blank ...
Status: RESOLVED DUPLICATE of bug 104683
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Formatting-Mark Character
  Show dependency treegraph
 
Reported: 2018-08-19 16:30 UTC by Telesto
Modified: 2021-07-31 10:29 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (9.59 KB, application/vnd.oasis.opendocument.text)
2018-08-19 16:54 UTC, Telesto
Details
Example file with left alignment (9.62 KB, application/vnd.oasis.opendocument.text)
2018-08-20 07:10 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-08-19 16:30:10 UTC
Description:
UI: No spacing formatting mark when pressing space at the end of the line

Steps to Reproduce:
1. Open the attached file
2. Formatting Marks enabled
2. Type 'argh' (without quotes) at the end of the line (containing bla bla). 
3. Press spacebar 


Actual Results:
No space 'dot' shown. Pressing space again isn't helping (invisible spaces are added (see bug 104683) 

Expected Results:
Pressing space should have some effect; its rather confusion without


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.0.0.alpha0+
Build ID: c0fdcece6b886912618deee9656cb2d169a9b999
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-08-12_00:35:45
Locale: en-US (nl_NL); Calc: CL

and in
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 1 Telesto 2018-08-19 16:54:49 UTC
Created attachment 144305 [details]
Example file
Comment 2 Dieter 2018-08-20 06:43:55 UTC
(In reply to Telesto from comment #0)
> Expected Results:
> Pressing space should have some effect; its rather confusion without

I know the problem, but what effect do you expect? A 'dot' ant the end of the line shouldn't be possible in a justified text.
Comment 3 Telesto 2018-08-20 07:10:20 UTC
Created attachment 144319 [details]
Example file with left alignment
Comment 4 Telesto 2018-08-20 07:21:24 UTC
> I know the problem, but what effect do you expect? A 'dot' ant the end of
> the line shouldn't be possible in a justified text.

MacOS Pages places the dot on the last character (not sure how Word handles this).
Anyhow lets simplify. The issue is no different with left alignment, so...
Comment 5 Dieter 2018-08-20 17:45:44 UTC
(In reply to Telesto from comment #4) 
> MacOS Pages places the dot on the last character (not sure how Word handles
> this).

Interesting solution

> Anyhow lets simplify. The issue is no different with left alignment, so...

I changed status to NEW
Comment 6 QA Administrators 2019-09-02 09:20:02 UTC Comment hidden (obsolete)
Comment 7 Dieter 2021-07-31 10:29:18 UTC
Still the same in

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: ac80ec817eb07c77a51bc0729985a473c734182e
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Rethinking the problem I would say it#s more an enhancement request than a bug. Therefor I add Design-Team for finding a proper solution.

*** This bug has been marked as a duplicate of bug 104683 ***