Bug 119374 - FILESAVE: Cannot save any file with a bezier curve created from a polygon (Linux-only)
Summary: FILESAVE: Cannot save any file with a bezier curve created from a polygon (Li...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.2.7.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Save
  Show dependency treegraph
 
Reported: 2018-08-19 23:59 UTC by xraf32
Modified: 2019-07-16 04:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screencast (1.11 MB, video/x-matroska)
2018-12-07 18:50 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xraf32 2018-08-19 23:59:28 UTC
Description:
My system is Debian Stretch 64-bit.





Steps to Reproduce:
1. Open Draw or Impress
2. Draw a polygon (does not matter if you close it or not)
3. In the "edit points" mode, click any point and click in the button "smooth transition". Now your polygon has at least one curved side
4. Try to save the file

Actual Results:
In Libreoffice 6.1.0.3 (stretch-backports 1:6.1.0-1~bpo9+2):

Error: "Error saving the document test:
Write Error.
The file could not be written."

In my previous version (stretch 1:5.2.7-1+deb9u4):

crash, no error message

Expected Results:
Save the file


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
If you delete the curved polygon, you can save the file normally. If you draw a curve instead of a polygon in step 2, the problem does not happen. I have reset my profile to factory settings and disabled and enabled all OpenCL settings, all with no avail.

I don't know how to file a bug both for draw and impress, so I did it for draw. But it happens on both, exactly the same.
Comment 1 Alex 2018-08-20 20:20:53 UTC
Interestingly I've had this issue recently on my Ubuntu LO 6.0.X series and have been meaning to file a report.

Tried to replicate on Win10 LO 6.1.0.3 and it saved just fine. Tried multiple times with various shapes.
Comment 2 Roman Kuznetsov 2018-09-06 07:10:27 UTC
don't repro in

Version: 6.1.1.1
Build ID: 2718b4a18dfcc6a54ebe5f7b801ee7a47fa81e0c
CPU threads: 4; OS: Windows 6.1; UI render: default; 
Locale: ru-RU (ru_RU); Calc: group threaded

only linux problem?
Comment 3 Buovjaga 2018-09-25 18:07:34 UTC
NEW per comment 1
Comment 4 Roman Kuznetsov 2018-12-07 16:54:49 UTC
(In reply to Buovjaga from comment #3)
> NEW per comment 1

don't repro in

Версия: 6.1.3.2
ID сборки: 86daf60bf00efa86ad547e59e09d6bb77c699acb
Потоков ЦП: 4; ОС:Linux 4.13; Отрисовка ИП: по умолчанию; VCL: gtk2; 
Локаль: ru-RU (ru_RU.UTF-8); Calc: group threaded

and in

Version: 6.2.0.0.beta1+
Build ID: e18c4c5f55f12725821e2d357f251ae1c548217a
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-2, Time: 2018-11-29_16:39:51
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

buovjaga, please retest it yourself
Comment 5 Mike Kaganski 2018-12-07 18:50:20 UTC
Created attachment 147363 [details]
Screencast

Confirm.

Version: 6.1.3.2
Build ID: 1:6.1.3~rc2-0ubuntu0.18.04.2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group threaded
Comment 6 Mike Kaganski 2018-12-08 09:54:53 UTC
Also repro with vanilla (DEB) Version: 6.1.3.2
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group threaded.

But cannot repro with Version: 6.3.0.0.alpha0+
Build ID: 4150627176623ca9abcf2317bbd178bc23914c7c
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 7 Roman Kuznetsov 2018-12-08 11:38:27 UTC
don't repro in

Версия: 6.2.0.0.beta1+
ID сборки: 5fd429a3e20d0fb91d96be9ded39f81325432509
Потоков ЦП: 4; ОС:Linux 4.18; Отрисовка ИП: по умолчанию; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-2, Time: 2018-12-01_09:52:45
Локаль: ru-RU (ru_RU.UTF-8); UI-Language: ru-RU
Calc: threaded

Kubuntu 18.10

may be it repro only in Gnome 3?
Comment 8 Buovjaga 2018-12-21 17:53:26 UTC
Like Mike, I repro with 6.1.3 (distro-packaged), but not with latest master.

I think this is enough to close.

Arch Linux 64-bit
Version: 6.1.3.2
Build ID: 6.1.3-2
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: gtk3_kde5; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 146f98e7100ae57ced080c7d9fa028f01df99ca8
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: gtk3_kde5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 20 December 2018
Comment 9 xraf32 2019-07-15 19:55:35 UTC
One year later, happened again yesterday with the latest version available from stretch-backports:

Version: 6.1.5.2
Build ID: 1:6.1.5-3~bpo9+1
CPU threads: 4; OS: Linux 4.9; UI render: default; VCL: gtk2; 
Locale: en-GB (en_GB.UTF-8); Calc: group threaded

Per the previous comments, this seems to be a problem with the distro packaging, but that is how most people in linux get LibreOffice from. 

So I have reopened this because if something is going wrong in the packaging, testing the latest non-distro-packaged master is not going to reproduce the bug but most people in Linux are still going to be affected by the bug. If this is not the right place to file this bug, can someone please point me to it?

Thanks and keep up this great work, LO is awesome
Comment 10 Buovjaga 2019-07-16 04:19:12 UTC
(In reply to xraf32 from comment #9)
> One year later, happened again yesterday with the latest version available
> from stretch-backports:
> 
> Version: 6.1.5.2
> Build ID: 1:6.1.5-3~bpo9+1
> CPU threads: 4; OS: Linux 4.9; UI render: default; VCL: gtk2; 
> Locale: en-GB (en_GB.UTF-8); Calc: group threaded

Still, you are using a version from the 6.1.x line. Please test with 6.2.x or 6.3.0.

In comment 6, Mike was able to reproduce with a TDF-packaged version, so you could try an appimage https://libreoffice.soluzioniopen.com/
Comment 11 xraf32 2019-07-16 04:34:44 UTC
(In reply to Buovjaga from comment #10)
> (In reply to xraf32 from comment #9)
> > One year later, happened again yesterday with the latest version available
> > from stretch-backports:
> > 
> > Version: 6.1.5.2
> > Build ID: 1:6.1.5-3~bpo9+1
> > CPU threads: 4; OS: Linux 4.9; UI render: default; VCL: gtk2; 
> > Locale: en-GB (en_GB.UTF-8); Calc: group threaded
> 
> Still, you are using a version from the 6.1.x line. Please test with 6.2.x
> or 6.3.0.
> 
> In comment 6, Mike was able to reproduce with a TDF-packaged version, so you
> could try an appimage https://libreoffice.soluzioniopen.com/

I didn't know this appimage stuff and it is awesome! Cannot reproduce in:

Version: 6.3.0.1
Build ID: 41ac97386aba908b6db860cfb4cfe2da871886ae
CPU threads: 4; OS: Linux 4.9; UI render: default; VCL: gtk2; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

Thanks!