Download it now!
Bug 119379 - Search after command in sidebar
Summary: Search after command in sidebar
Status: RESOLVED DUPLICATE of bug 91874
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.1.0.0.beta1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-20 09:14 UTC by andreas_k
Modified: 2018-08-21 13:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
customize dialogue (31.32 KB, image/png)
2018-08-20 09:14 UTC, andreas_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2018-08-20 09:14:33 UTC
Created attachment 144323 [details]
customize dialogue

Search after .uno: commands would be very usefull for not that common actions. In addition it could also help the developers.

When you go to tools -> customize everything is there for show the different commands. So have the same thing in the sidebar and when you click on the action it will be used should be not to difficult.

I would prefer to show in the sidebar by default the search and the last 10 used commands, but with the drop down menu you can switch to see everything.
Comment 1 Heiko Tietze 2018-08-21 08:55:15 UTC
needsUXEval needs CC libreoffice-ux-advise@lists.freedesktop.org
Comment 2 Heiko Tietze 2018-08-21 08:57:06 UTC
Absolutely, and it is requested frequently.

*** This bug has been marked as a duplicate of bug 91874 ***
Comment 3 V Stuart Foote 2018-08-21 13:17:40 UTC
I think Anreas's request is for a *dedicated* content panel for searching for functions implemented on the Sidebar, not clear that duplicates bug 91874 where scope is to search for Menu entries.

Will especially needed should work on bug 33223 gain traction to implement GUI driven customization to "roll your own" Sidebar content panels.
Comment 4 andreas_k 2018-08-21 13:27:36 UTC
I am searching always for something that can be easy implemented and as I wrote all functions are available in the customize dialogue. There is the search, the dropdown filter and the endless list, so move the existing items in the sidebar and the only needed change is that when you click one item in the list it will run the uno command instead of move the item somewhere.