Download it now!
Bug 119382 - EDITING: Rearranging columns in table grid control adds duplicate of column to grid
Summary: EDITING: Rearranging columns in table grid control adds duplicate of column t...
Status: RESOLVED DUPLICATE of bug 54021
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.4.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-20 10:38 UTC by Drew Jensen
Modified: 2018-08-20 19:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
example form (12.58 KB, application/vnd.oasis.opendocument.database)
2018-08-20 10:39 UTC, Drew Jensen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Drew Jensen 2018-08-20 10:38:26 UTC
Description:
If you use the mouse to rearrange the columns in a table grid on a form the control duplicates the column where you move it to, while leaving the old column at the original position.

Test on Ubuntu 18.04 (gnome) with libo version 5.4, 6.0, 6.1, 6.2 alpha

Steps to Reproduce:
1. Open attached database ODB file
2. Open single form in the database in EDIT mode
3. Try to rearrange the columns by clicking on a column header with you mouse and while holding the mouse button down move it to the left or right. When you have it where you want it release the mouse button:

Actual Results:
A second instance of the column is added to grid.


Expected Results:
The column position of the original column is changed.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Drew Jensen 2018-08-20 10:39:34 UTC
Created attachment 144327 [details]
example form

The example is embedded firebird, but the data engine doesn't matter here.
Comment 2 Robert Großkopf 2018-08-20 14:22:38 UTC
Isn't this a duplicate of bug 54021? I have had named it "tablecontrol", not "table grid control". Have a look for all the bugs of "tablecontrol".
Comment 3 Drew Jensen 2018-08-20 19:18:36 UTC
(In reply to robert from comment #2)
> Isn't this a duplicate of bug 54021? I have had named it "tablecontrol", not
> "table grid control". Have a look for all the bugs of "tablecontrol".

yes

*** This bug has been marked as a duplicate of bug 54021 ***