Bug 119422 - LibreOffice does not remember last default location.
Summary: LibreOffice does not remember last default location.
Status: RESOLVED DUPLICATE of bug 119133
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-22 13:06 UTC by wg91
Modified: 2018-08-30 13:43 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wg91 2018-08-22 13:06:36 UTC
Description:
When I open up a file that has already been saved in a folder and try to "Save As" back to that default location, it doesn't remember where it was saved and it doesn't remember the name of the file.  So now when I save a file back to its default location, I have to name the file again and click all the way through the file manager back to where I want to save it.

I'm running Manjaro Linux KDE LibreOffice Writer version: Version: 6.1.0.3
Build ID: 6.1.0-1

Steps to Reproduce:
1.  Open up a file that has already been saved.
2.  Click "Save As"
3.  A window pops up asking me where to save the file and it has no name.  So it doesn't remember where it was originally saved or the name of the file.

Actual Results:
1.  Open up a file that has already been saved.
2.  Click "Save As"
3.  A window pops up asking me where to save the file and it has no name.  So it doesn't remember where it was originally saved or the name of the file.

Expected Results:
I have to click through the file manager back to the default location and rename the file.


Reproducible: Always


User Profile Reset: No



Additional Info:
It should remember the default save location of wherever I saved it and it should remember the name of the original file.
Comment 1 Jean-Baptiste Faure 2018-08-22 13:41:56 UTC
Not reproducible for me with LO 6.1.1.0.0+ under Ubuntu 18.04 with Gnome Shell.

Best regards. JBF
Comment 2 wg91 2018-08-22 17:40:02 UTC
Confirmed on both of my machines running Manjaro KDE.  I will roll back to the previous version of LibreOffice that was just updated to see if it resolves the issue.
Comment 3 Xisco Faulí 2018-08-23 08:22:30 UTC
I can't reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: 60bc26354763fa3461db49a3e827da552484150d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

To be certain the reported issue is not related to corruption in the user profile, could you please reset your Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 4 Xisco Faulí 2018-08-23 08:22:52 UTC
Could you also please paste the info from Help - about LibreOffice ?
Comment 5 wg91 2018-08-29 18:21:00 UTC
(In reply to Xisco Faulí from comment #4)
> Could you also please paste the info from Help - about LibreOffice ?

I reset the user profile in safe mode but still had the same problem.  Here is the help info:

Version: 6.1.0.3
Build ID: 6.1.0-2
CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: gtk3_kde5; 
Locale: en-US (en_US.UTF-8); Calc: group threaded
Comment 6 Xisco Faulí 2018-08-30 09:49:31 UTC
Do you reproduce this problem if you execute LibreOffice like 'SAL_USE_VCLPLUGIN=gen soffice' ?
Comment 7 wg91 2018-08-30 13:28:29 UTC
I don't understand what that means.  If you have instructions on how to do that I can try it.
Comment 8 Maxim Monastirsky 2018-08-30 13:36:22 UTC
Probably a duplicate of Bug 119133. Please try again with version 6.1.1

*** This bug has been marked as a duplicate of bug 119133 ***
Comment 9 wg91 2018-08-30 13:43:54 UTC
Yes, this other bug is identical to what I've been experiencing.  I'll have to wait until the Manjaro packagers update Libreoffice in pacman.

I installed the Flatpak version of LibreOffice which does not have this bug and it's working great.

I will test it however once 6.1.1 is updated in Manjaro.

Thanks for the help!