Bug Hunting Session
Bug 119462 - Find with formatting adds 0pt text size
Summary: Find with formatting adds 0pt text size
Status: VERIFIED DUPLICATE of bug 120031
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0 target:6.3.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Find-Search
  Show dependency treegraph
 
Reported: 2018-08-23 19:43 UTC by David Bolton
Modified: 2018-12-06 06:37 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Bolton 2018-08-23 19:43:51 UTC
Description:
If you try to find Bold text it also adds a 0pt text size criteria.

Steps to Reproduce:
1. Choose Edit > Find & Replace
2. Choose Format
3. Choose Bold
4. Choose OK

Actual Results:
Underneath the Find input box it says, "0 pt, bold" (or if this is the second time you try it is says "2 pt, bold"

Expected Results:
Underneath the Find input box it should only say "Bold"


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.0.3 (x64)
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: en-US (en_US); Calc: CL
Comment 1 raal 2018-08-23 20:41:43 UTC
This seems to have begun at the below commit.
Adding Cc: to Mike Kaganski ; Could you possibly take a look at this one?
Thanks

8d7b3ac2473b6cb4c2b8938ecd682208972154cf is the first bad commit
commit 8d7b3ac2473b6cb4c2b8938ecd682208972154cf
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Wed Feb 21 09:04:38 2018 +0100

    source sha:f00e891f3369f7b8c2532634d9ff4ab19da17c33

author	Mike Kaganski <mike.kaganski@collabora.com>	2018-02-21 00:30:16 +0300
committer	Mike Kaganski <mike.kaganski@collabora.com>	2018-02-21 08:11:23 +0100
commit	f00e891f3369f7b8c2532634d9ff4ab19da17c33 (patch)
tree	752901b046836b0aab906cd7966a178636bf290e
parent	ba8a70365ef459c967cd8a71a6d48ca53dd341bd (diff)
tdf#115892: properly get the box' saved value
Comment 2 Xisco Faulí 2018-09-22 00:13:56 UTC
Issue fixed by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=9237a905fa5f2b67db73c15847eff203a258c2b4

author  Caolán McNamara <caolanm@redhat.com>    2018-09-10 17:19:19 +0100
committer       Caolán McNamara <caolanm@redhat.com>    2018-09-14 11:43:51
+0100
commit  9237a905fa5f2b67db73c15847eff203a258c2b4 (patch)
tree    bf213e7f3fd7322ee032af9fa648d04c99faaba1
parent  34f6b7f4529cc5a3b0e286fbd7318c2b7bf9b132 (diff)
weld SvxCharNamePage

@Caolán, any chance only the fix for this issue could be backported to 6.1 branch?
Comment 3 Thomas Lendo 2018-10-04 11:48:06 UTC
Verified that the issue has gone.

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 89a60912bba7ffd6f65ea99f4664f343c5025c95
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-01_03:18:33
Locale: de-AT (de_AT); Calc: CL
Comment 4 Caolán McNamara 2018-10-04 13:41:50 UTC
Same problem as bug 120031

*** This bug has been marked as a duplicate of bug 120031 ***
Comment 5 BogdanB 2018-10-22 14:22:08 UTC
Verified. Fixed.

Version: 6.2.0.0.alpha0+
Build ID: 3846561f79cf9065abd9ca83c9fbfbe7e52e28e2
CPU threads: 4; OS: Linux 4.15; UI render: GL; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-10-21_02:45:54
Locale: en-US (ro_RO.UTF-8); Calc: threaded
Comment 6 Commit Notification 2018-12-06 06:37:47 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/fcc76610649a9830859f9e2efe2a06dbc6db74da%5E%21

uitest for bug tdf#119462

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.