Bug Hunting Session
Bug 119466 - Problems with bitmap backgrounds and patterns
Summary: Problems with bitmap backgrounds and patterns
Status: RESOLVED DUPLICATE of bug 118976
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Paragraph-Dialog
  Show dependency treegraph
 
Reported: 2018-08-24 03:00 UTC by Leandro Martín Drudi
Modified: 2018-08-28 10:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Bitmap error (132.10 KB, image/png)
2018-08-24 03:01 UTC, Leandro Martín Drudi
Details
Pattern editor and preview (25.21 KB, image/png)
2018-08-24 03:03 UTC, Leandro Martín Drudi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leandro Martín Drudi 2018-08-24 03:00:58 UTC
Description:
1) Bits Map and patterns preview are not displayed correctly.
2) Pattern editing does not work correctly.

Steps to Reproduce:
BITMAP
1. Open LibreOffice.
2. Create a new Write document.
3. Go Format -> Paragraf -> Area -> Bitmap

PATTERN:
1. Open LibreOffice.
2. Create a new Write document.
3. Go Format -> Paragraf -> Area -> Pattern

Actual Results:
BITMAP:
The preview area show a skyblue color. If you change the bitmap, the preview area don't show anythin that color.

PATTERN:
The preview area show a skyblue color. If you change the bitmap, the preview area don't show anythin that color.
The pattern editor shows "black pixels" even when these are not part of the pattern. When editing some, the changes are not reflected in the preview and some can not change color (with right click or left click) remaining blank or being black (punctually the A1 pixel). This happens also in Draw.

Expected Results:
Diferent preview and editor like the pattern.


Reproducible: Always


User Profile Reset: No



Additional Info:
This happens in a clean instalation.
Comment 1 Leandro Martín Drudi 2018-08-24 03:01:51 UTC
Created attachment 144406 [details]
Bitmap error

The preview don't show the selected bitmap.
Comment 2 Leandro Martín Drudi 2018-08-24 03:03:30 UTC
Created attachment 144407 [details]
Pattern editor and preview

THe preview don't show the selected pattern.
The pattern editor shows painted pixels even if they are not part of the pattern.
Comment 3 Dieter Praas 2018-08-24 07:03:56 UTC
I can't reproduce it with

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 414ef6cb187dd3bbcc917dbedf3c0c1cc8668f60
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-08-21_00:13:04
Locale: en-US (de_DE); Calc: CL
Comment 4 Xisco Faulí 2018-08-28 10:53:29 UTC
Thanks for reporting this issue.
This is a duplicate of bug 118976 and it will be fixed in LibreOffice 6.1.1.
Thanks!

*** This bug has been marked as a duplicate of bug 118976 ***