Bug 119481 - When Saving As, changing from Open Document format to something else in the dropdown does not change the file extension (Linux-only)
Summary: When Saving As, changing from Open Document format to something else in the d...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All Linux (All)
: highest normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Save
  Show dependency treegraph
 
Reported: 2018-08-24 14:51 UTC by Elmar
Modified: 2018-10-20 04:54 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
video - reproducing the bug? (2.75 MB, video/mp4)
2018-09-24 15:10 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Elmar 2018-08-24 14:51:21 UTC
Description:
When I try to save a presentation, impress reverses selection

Steps to Reproduce:
1. save document to odp
2. save again, change selection to pptx
3. click save
4. asks if want to overwrite odp
5. see that selection has reverted to odp
6. open file in v6.0
7. save to pptx
8. open pptx in v6.2dev
9. make a change
10 save - works fine

Actual Results:
asks if want to overwrite the odp file

Expected Results:
should save to pptx


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: PresentationDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Version: 6.2.0.0.alpha0+
Build ID: 414ef6cb187dd3bbcc917dbedf3c0c1cc8668f60
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-08-21_00:40:09
Locale: en-ZA (en_ZA.UTF-8); Calc: threaded
Comment 1 raal 2018-08-27 19:02:35 UTC
I can not confirm- save as pptx works
Version: 6.2.0.0.alpha0+
Build ID: 58f2e4690b57f0fa7a95be3a023d54d8967f5529
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-08-23_23:45:59
Comment 2 Buovjaga 2018-09-23 11:17:58 UTC
Repro, selecting format from the dropdown. Obviously if we write the .pptx in the name field, it will work.

Problem is seen with all VCL backends except gtk3_kde5! Problem is not limited to Impress.
No problem on Windows

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 8b1501d80dc9d3f42c351c6e026fa737e116cae5
CPU threads: 8; OS: Linux 4.18; UI render: default; VCL: gtk2; 
Locale: fi-FI (fi_FI.UTF-8); Calc: threaded
Built on 23 September 2018
Comment 3 Elmar 2018-09-24 05:09:51 UTC
Has not been a problem in recent downloads (after 21Aug).
Comment 4 Buovjaga 2018-09-24 07:06:23 UTC
Ehh, I just confirmed it is still a problem with very recent builds :)
Comment 5 BogdanB 2018-09-24 15:10:37 UTC
Created attachment 145139 [details]
video - reproducing the bug?

Hi, please see the video.
I consider to be ok to ask me if I want ODF or PPTX... If I choose PPTX it is saving in PPTX... In version 6.0 the difference is that is not asking what I want, and maybe I can lose some aspects savong in PPTX comapring to ODF (like the message warn us).
Comment 6 Buovjaga 2018-09-24 15:35:04 UTC
(In reply to BogdanB from comment #5)
> Created attachment 145139 [details]
> video - reproducing the bug?
> 
> Hi, please see the video.
> I consider to be ok to ask me if I want ODF or PPTX... If I choose PPTX it
> is saving in PPTX... In version 6.0 the difference is that is not asking
> what I want, and maybe I can lose some aspects savong in PPTX comapring to
> ODF (like the message warn us).

You did not reproduce the bug. If you had reproduced it, it would have saved as ODP even though you selected PPTX.
Comment 7 Xisco Faulí 2018-09-24 17:05:03 UTC
I can't reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: 66232248ff55639052ddb76918d555e21dc9c46b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded
Comment 8 Buovjaga 2018-09-24 17:23:13 UTC
Bah, now I tried with safe mode and could not repro. Still reliably repro'd with old profile.

Crazy that we can apparently hit the same sort of profile problems (?) 1 month apart. I cleared my profile like 3 days ago!
Comment 9 Elmar 2018-09-25 05:27:22 UTC
Has not been an issue with 17 and 21 Sep downloads of LO