Bug Hunting Session
Bug 119488 - [feature request] Provide REGEXSEARCH/REGEXEXTRACT function to avoid performance issues
Summary: [feature request] Provide REGEXSEARCH/REGEXEXTRACT function to avoid performa...
Status: CLOSED DUPLICATE of bug 113977
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.7.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-24 20:11 UTC by Maddes
Modified: 2018-10-24 09:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maddes 2018-08-24 20:11:32 UTC
If a document uses a lot of SEARCH and VLOOKUP functions, then enabling regular expressions globally in a Calc document leads to an extreme performance hit.
Most of the time it turns out that only the SEARCH function needs RegEx support to get a value, while the VLOOKUPs just search for that found value.

Providing a REGEXSEARCH function, as done by Google Docs' REGEXEXTRACT [1], would help to keep the performance hit low, as RegEx would only be used when necessary. THis would also avoid additional escaping in VLOOKUPs.

Thanks for reading
Maddes

[1] https://support.google.com/docs/answer/3098244
Comment 1 Eike Rathke 2018-10-24 09:04:35 UTC

*** This bug has been marked as a duplicate of bug 113977 ***