Download it now!
Bug 119505 - LibreOffice doesn' respect umask on overwriting
Summary: LibreOffice doesn' respect umask on overwriting
Status: RESOLVED DUPLICATE of bug 119050
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-26 08:58 UTC by deant
Modified: 2018-08-27 08:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
pdf showing the bug (391.15 KB, application/pdf)
2018-08-26 08:58 UTC, deant
Details

Note You need to log in before you can comment on or make changes to this bug.
Description deant 2018-08-26 08:58:58 UTC
Created attachment 144444 [details]
pdf showing the bug

Tested on debian/buster with LibreOffice_6.1.0_Linux_x86-64_deb.tar.gz

I have umask set to 0007. I want the files to be created with permission 660 on my system.
1. I open libreoffice and create new spreadsheet. I save the spreadsheet and i close libreoffice.
2.Checking with ls -la shows that the file has correct permission rw-rw----.
3.Opening the same file again and I am OVERWRITING it.
4.Cheking again with ls -la before we close the file. I noticed that the lock file still has  rw-rw----, but the original file has been changed to rw-------.
5. Closing the file and again checking the permisions - ls -la - the lock file is gone (as it should be), but the permissions of the original file are still rw-rw----.

No idea which versions are affected, but this actualy stops my production and i cannot find a workaround.
Comment 1 deant 2018-08-26 09:11:45 UTC
I just tested version 6.0's debian package. It DOESNT have this bug!
Comment 2 deant 2018-08-26 09:52:10 UTC
on step 5, there is a typo: rw-rw---- should be rw-------. After overwriting permissions remain rw-r------
Comment 3 deant 2018-08-26 09:53:09 UTC
on step 5, there is a typo: rw-rw---- should be rw-------. After overwriting permissions remain rw--------
Comment 4 Xisco Faulí 2018-08-27 08:59:37 UTC
Thanks for reporting this issue.
This is a duplicate of bug 119050

*** This bug has been marked as a duplicate of bug 119050 ***