Bug 119565 - FILESAVE XLSX Line property of shape inherited from theme lost
Summary: FILESAVE XLSX Line property of shape inherited from theme lost
Status: RESOLVED DUPLICATE of bug 97057
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:xlsx, regression
Depends on:
Blocks:
 
Reported: 2018-08-28 14:13 UTC by Gabor Kelemen
Modified: 2018-09-11 09:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Line properties when opening attachment #144508 in Excel and Calc (109.76 KB, image/png)
2018-08-28 14:13 UTC, Gabor Kelemen
Details
The line properties in Calc-saved attachment #144510 (95.27 KB, image/png)
2018-08-28 14:14 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2018-08-28 14:13:33 UTC
Created attachment 144514 [details]
Line properties when opening attachment #144508 [details] in Excel and Calc

LibreOffice Calc imports fine, but losts during export the line property of shapes in XLSX files, when the shape was created in Microsoft Excel with default properties. If we change the properties (like thickness or color) of the line, the line is preserved. This bug is most likely related to (or even duplicate of) a similar bug #97057 which causes the theme color to be lost when the shape is saved.

Steps to reproduce:
    1. Create a new spreadsheet in Microsoft Excel
    2. Insert a shape with default properties. Do not change anything after the shape has been inserted!
    3. Save the spreadsheet as XLSX and close it. For example: attachment #144508 [details]
    4. Open the same file in LibreOffice Calc.
    5. Save the file as XLSX and reload it.

Actual results:
Both the background color (as we saw in the bug #97057) and the line properties of the shape are lost.

Expected results:
The line properties should be preserved (and also the background color, although that's a different, but most likely related bug).

LibreOffice details:
Version: 6.2.0.0.alpha0+
Build ID: af579ed7d1482df5cfa7e12e8af2603917d40602
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: hu-HU (hu_HU); Calc: CL
Comment 1 Gabor Kelemen 2018-08-28 14:14:56 UTC
Created attachment 144515 [details]
The line properties in Calc-saved attachment #144510 [details]
Comment 2 raal 2018-09-05 21:00:30 UTC
I can confirm with Version: 6.2.0.0.alpha0+
Build ID: 4b5fcd417587cfb9e6d8b61ecb037ab165eeb5b9
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3;
Comment 3 Xisco Faulí 2018-09-06 09:33:10 UTC
I can also reproduce it in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

but not in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 4 Xisco Faulí 2018-09-06 09:42:38 UTC
bibisect-43max points to 4a969ac35174520f1ffeb4f919f5d7bb6d99a628.
Searching for this hash in Bugzilla points to bug 97057, which makes sense...
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 97057 ***