Bug 119597 - Page Contextmenu in Writer, Calc, Draw and Impress
Summary: Page Contextmenu in Writer, Calc, Draw and Impress
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Context-Menu
  Show dependency treegraph
 
Reported: 2018-08-29 22:58 UTC by andreas_k
Modified: 2018-11-01 10:09 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Contextmenu Page for Writer, Calc, Draw and Impress (437.71 KB, image/png)
2018-08-29 22:58 UTC, andreas_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2018-08-29 22:58:52 UTC
Created attachment 144543 [details]
Contextmenu Page for Writer, Calc, Draw and Impress

Page is available "only" in draw and impress and there the arrangement has a bit changed. The reason is that properties are always the last group in context menu. 

Page submenu was moved out of the submenu, cause you are in the page context menu so no need for an second subgroup.
Comment 1 Thomas Lendo 2018-09-08 23:49:49 UTC
Impress: no objections.

Draw:
- Have you moved 'Insert Snap Guide...' command into the 'Snap Guides' sub-menu?
- Where are the 'Rename page' and 'New paage' commands?

Calc:
- The 'Format Cells...' command is the most important item and comparable to the properties item in page and image context menus. In your proposal it seems a little bit inadequately visible.
- Why have you added 'Define'? Is there a bug or discussion that recommends that?

Writer:
- 'Clear direct formatting' is very good.
- Maybe an 'Insert comment...' command would also be good as it is part of Calc's context menu too.
Comment 2 Heiko Tietze 2018-11-01 09:51:34 UTC
Removing needsUX as there was agreement. But the context menus have been reworked so this issue could probably be resolved.