Bug 119622 - text on slide is inaccessible and undisplayed in presentation mode
Summary: text on slide is inaccessible and undisplayed in presentation mode
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.1.1 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords: bibisected, regression
Depends on:
Blocks: Slide-Show
  Show dependency treegraph
 
Reported: 2018-08-31 15:05 UTC by muso
Modified: 2020-04-11 05:42 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
The 2 slide test case (26.61 KB, application/vnd.oasis.opendocument.presentation)
2018-08-31 15:05 UTC, muso
Details
The original PowerPoint file (208.00 KB, application/x-ole-storage)
2018-08-31 15:06 UTC, muso
Details
LO 6.1.2.1 about dialog (66.96 KB, image/jpeg)
2018-09-24 22:43 UTC, muso
Details

Note You need to log in before you can comment on or make changes to this bug.
Description muso 2018-08-31 15:05:47 UTC
Created attachment 144582 [details]
The 2 slide test case

- Open the attached presentation
- you can see on the second slide some text
-try to edit the text or move it around

result: the text on slide 2 cannot be accessed. Moreover, when starting the presentation, the text is also not displayed

- now delete the first slide

result: now you can access the text that was not accessible before.

The presentation file is an excerpt form a PowerPoint file created with Office XP in 2003. I attached the original PowerPoint too as reference.
Comment 1 muso 2018-08-31 15:06:51 UTC
Created attachment 144583 [details]
The original PowerPoint file

The Powerpoint file was created with Office XP and last saved in 2003.
Comment 2 m.a.riosv 2018-09-01 00:10:34 UTC
On the second file it's possible to edit the main text from fourth slide, editable with outline view, and it's editable Title¡s text and the text on the arrow of the first slide. 

Wit the first file I can edit the text.

Version: 6.1.1.1 (x64)
Build ID: 2718b4a18dfcc6a54ebe5f7b801ee7a47fa81e0c
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: es-ES (es_ES); Calc: CL
Comment 3 muso 2018-09-04 12:50:49 UTC
> Wit the first file I can edit the text.

With the first file (the one that has only 2 slides) I cannot edit the text on the second slide and this is the bug I reported here.
Comment 4 Xisco Faulí 2018-09-04 14:12:05 UTC
I can't reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: bf8fbbaa683ef7eef5f9587b60486f622b50cb80
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 5 muso 2018-09-04 18:03:22 UTC
> could you please reset your Libreoffice profile

Done but the problem persists with the file I uploaded. To assure that there is no server issue, I downloaded the file I uploaded and opened it with LO in safe mode where I reset all user preferences, extensions and settings.

> I can't reproduce it in Version: 6.2.0.0.alpha0+

Please test with the latest version that is available for normal users. It doesn't help use normal users if a bug might be fixed in a version that will be released in a few months. For us it is important that you can reproduce the bug and if it is fixed in 6.2alpha but not fixed in 6.1.1 then I would be happy if could kindly backport the fix to the 6.1 series.
Comment 6 Buovjaga 2018-09-24 18:30:09 UTC
muso: like Miguel said, it works fine in 6.1.1. I confirm I can edit the text in slide 2 of attachment 144582 [details]

Please copy and paste here the contents of your Help - About. This allows us to know more about your system.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.

Arch Linux 64-bit
Version: 6.1.1.2
Build ID: 6.1.1-1
CPU threads: 8; OS: Linux 4.18; UI render: default; VCL: gtk3_kde5; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Comment 7 muso 2018-09-24 22:43:46 UTC
Created attachment 145145 [details]
LO 6.1.2.1 about dialog
Comment 8 muso 2018-09-24 22:44:00 UTC
The problem persist for me with LO 6.1.2.1.
I use Windows 7, 64bit, see also the attached about dialog of LO.
Comment 9 Buovjaga 2018-09-25 09:39:30 UTC
(In reply to muso from comment #8)
> The problem persist for me with LO 6.1.2.1.
> I use Windows 7, 64bit, see also the attached about dialog of LO.

Thanks. For the future, just copy and paste the text, there is no need to take a screenshot.
Comment 10 Xisco Faulí 2018-10-26 10:12:18 UTC
I can reproduce it in

Versión: 6.1.2.1
Id. de compilación: 65905a128db06ba48db947242809d14d3f9a93fe
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threaded

but not in

Version: 6.2.0.0.alpha1+
Build ID: cd6dd8c6f3562cbccbc971b916c6a8933840ffeb
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

seem to be Win only...
Comment 11 Xisco Faulí 2018-10-26 10:19:08 UTC
Reproduced in

Version: 6.2.0.0.alpha0+
Build ID: 3f9c477929c261a8862411c00153e4c7d0d0ae7c
CPU threads: 16; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-GB (en_GB); Calc: threaded

but not in

Version: 5.3.0.0.alpha1+
Build ID: 4136757b4e51c4e6f7cb4132c95538a7f831ef2c
CPU Threads: 16; OS Version: Windows 6.29; UI Render: default; Layout Engine: new; 
Locale: en-GB (en_GB); Calc: group
Comment 12 Xisco Faulí 2018-10-26 10:44:41 UTC
So, it was fine until https://cgit.freedesktop.org/libreoffice/core/commit/?id=1da3a3cb74a415a76fa547ef0c8f61780e260e7f, when the slides became blank. Then the blank problem got fixed https://cgit.freedesktop.org/libreoffice/core/commit/?id=f0485ba2d90aae0312f5775588f22789016165d2 and this issue became reproducible...

Adding Cc: to Tamás Zolnai
Comment 13 Roman Kuznetsov 2019-04-02 07:56:45 UTC
don't repro in

Version: 6.2.1.1
Build ID: 757c58e8cb70b2982843211a54750fb3cd79acd5
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 14 muso 2019-04-02 12:41:14 UTC
I can confirm that this bug is fixed in LO 6.2.2.1
Comment 15 Aron Budea 2020-04-11 05:42:06 UTC
1da3a3cb74a415a76fa547ef0c8f61780e260e7f was reverted in 6.2.