Download it now!
Bug 119624 - LibreOffice quit confirmation dialog shows cancel icon below label
Summary: LibreOffice quit confirmation dialog shows cancel icon below label
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.2.0 target:6.1.3
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-31 16:46 UTC by Mélanie «ariasuni» Chauvel
Modified: 2018-09-26 19:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Dialog in English (12.00 KB, image/png)
2018-08-31 16:46 UTC, Mélanie «ariasuni» Chauvel
Details
Dialog in French (12.40 KB, image/png)
2018-08-31 16:47 UTC, Mélanie «ariasuni» Chauvel
Details
Dialog in French (Breeze GTK3 theme) (11.39 KB, image/png)
2018-09-04 10:04 UTC, Mélanie «ariasuni» Chauvel
Details
Dialog in Greek (Ambiant-MATE theme) (31.87 KB, image/png)
2018-09-24 11:50 UTC, Kosmas M.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mélanie «ariasuni» Chauvel 2018-08-31 16:46:15 UTC
Description:
Shows icon below «Cancel» instead of before like «Save»

Steps to Reproduce:
1. Open a new document
2. Edit something
3. Try to close the document/window

Actual Results:
The dialog that appears has the icon below the the label for Cancel action

Expected Results:
The icon should appears before the label like for Save


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Mélanie «ariasuni» Chauvel 2018-08-31 16:46:48 UTC
Created attachment 144585 [details]
Dialog in English
Comment 2 Mélanie «ariasuni» Chauvel 2018-08-31 16:47:08 UTC
Created attachment 144586 [details]
Dialog in French
Comment 3 Julien Nabet 2018-09-02 05:32:54 UTC
On pc Debian testing x86-64 with LO Debian package 6.1.1.1, I don't reproduce this (gtk3, gtk, gen or kde4 rendering). I gave a try with Writer

Which Linux distrib do you use?
Do you reproduce this on every LO module or just a specific one?
Did you install any specific LO extensions?
Do you use accessibility component?
For the test, could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#GNU.2FLinux) and give a new try?
Comment 4 Mélanie «ariasuni» Chauvel 2018-09-03 23:21:35 UTC
– I use Arch Linux
– The problem is with GTK3 backend under Plasma (I can’t get the kde4 one to work, but the other don’t have icons anyway)
– The problem is the same with a brand new profile with no extension or configuration
– The problem happens with every module
Comment 5 Xisco Faulí 2018-09-04 09:56:28 UTC
Do you reproduce it if you use another theme in your OS ?
Comment 6 Mélanie «ariasuni» Chauvel 2018-09-04 10:04:39 UTC
Created attachment 144663 [details]
Dialog in French (Breeze GTK3 theme)

I can reproduce the bug with other themes, here with Breeze.
Comment 7 Julien Nabet 2018-09-04 19:28:06 UTC
How to get icons in the dialog?
I searched in options, I just found "Icon in menus" but that's all.
Also in 6.1.1, the order is different, I got:
- Don't Save
- Cancel
- Save
Comment 8 Kosmas M. 2018-09-24 11:47:29 UTC
I got the same problem in Ubuntu MATE 18.04 with the Libreoffice-fresh PPA (6.1.1.2) regardless of the theme (tested with all stock themes provided in Ubuntu MATE) or the module (tested with all of them).

Happens every time an unsaved file is exited. (and it annoys me more than it probably should...)
Comment 9 Kosmas M. 2018-09-24 11:50:39 UTC
Created attachment 145137 [details]
Dialog in Greek (Ambiant-MATE theme)

This is the confirmation message on Writer with the default Ubuntu MATE theme (Ambiant-MATE) and el-locale. The buttons from left to right are: "Don't save", "Cancel" and "Save". The affected icon is the cancel one, should be the same as "Save".
Comment 10 Julien Nabet 2018-09-24 12:21:55 UTC
Caolán: thought you might be interested in this one since it concerns gtk3 and it has just been confirmed.

(BTW, I didn't know how to reproduce this)
Comment 11 Caolán McNamara 2018-09-24 12:53:56 UTC
someone must have had fat fingers and accidentally toggled on bottom pos for the icon, and as icons are off by default it wasn't seen
Comment 12 Commit Notification 2018-09-24 14:33:34 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=95e9f79199e02550ce579085710b8c04cadbe015

Resolves: tdf#119624 stray image_position bottom for some icons in buttons

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Caolán McNamara 2018-09-24 14:44:14 UTC
backport to 6-1 in gerrit
Comment 14 Commit Notification 2018-09-24 15:10:24 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b20f09d765782b17aded592f30b41bba15fd8403&h=libreoffice-6-1

Resolves: tdf#119624 stray image_position bottom for some icons in buttons

It will be available in 6.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Kosmas M. 2018-09-25 08:43:53 UTC
I would love to help, I downloaded the latest 6.1 daily but I have no idea how to turn on the icons (and I don't even know how to search for that).
Comment 16 Adolfo Jayme 2018-09-26 16:13:49 UTC
It’s not surprising people don’t know how to enable icons under GNOME. You have to use dconf-editor to do that. Seriously. GNOME truly hates its users.
Comment 17 Julien Nabet 2018-09-26 19:31:02 UTC
(In reply to Adolfo Jayme from comment #16)
> It’s not surprising people don’t know how to enable icons under GNOME. You
> have to use dconf-editor to do that. Seriously. GNOME truly hates its users.

I took a look to http://ubuntuhandbook.org/index.php/2013/11/ubuntu-unity-menu-button-have-icons/ but key "buttons-have-icons" in org.gnome.desktop.interface doesn't even exist in my laptop (Debian testing)