Bug 119648 - Crash if I click on Fontwork Shape: Arch Left, Arch Right (Pour or Curve).
Summary: Crash if I click on Fontwork Shape: Arch Left, Arch Right (Pour or Curve).
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: x86-64 (AMD64) All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0 target:6.1.4
Keywords: bibisected, haveBacktrace, regression
Depends on:
Blocks: FontWork-WordArt
  Show dependency treegraph
 
Reported: 2018-09-02 17:26 UTC by Qaziro
Modified: 2018-12-26 13:01 UTC (History)
7 users (show)

See Also:
Crash report or crash signature: ["SdrObjList::GetObj(unsigned int)"]
Regression By:


Attachments
Shapes causing the problem. (22.58 KB, image/jpeg)
2018-09-02 17:33 UTC, Qaziro
Details
gdb backtrace (24.27 KB, text/plain)
2018-09-03 09:27 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Qaziro 2018-09-02 17:26:33 UTC
Description:
The LibreOffice crashes if I click on Fontwork Shape: Arch Left, Arch Right (Pour and Curve).

Steps to Reproduce:
1. Click on the Fontwork icon on the Drawing toolbar.
2. Choose any Fontwork style from the Fontwork Gallery.
3. Click on the Fontwork Shape icon on the Drawing toolbar..
4. Click on the icon Arch Left or Arch Right (Pour or Curve).

Actual Results:
LibreOffice crashed.

Expected Results:
Change the shape of the Fontwork text to Arch Left or Arch Right.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.1.0.3
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
Locale: en-US (en_UA.UTF-8); Calc: group threaded

Version: 6.1.0.3 (x64)
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 4; OS:Windows 6.1; UI render: default; 
Locale: ru-RU (ru_RU); Calc: group threaded
Comment 1 Qaziro 2018-09-02 17:33:11 UTC
Created attachment 144613 [details]
Shapes causing the problem.
Comment 2 Dieter 2018-09-02 18:05:28 UTC
I confirm this with

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 414ef6cb187dd3bbcc917dbedf3c0c1cc8668f60
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-08-21_00:13:04
Locale: en-US (de_DE); Calc: CL

But not with

Version: 6.0.6.2 (x64)
Build-ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 3 Xisco Faulí 2018-09-03 09:24:42 UTC
The crash is reproducible since https://cgit.freedesktop.org/libreoffice/core/commit/?id=2dadf90aa7bb03d895abc05ec93ca116eb9bacbd, before this commit, it is not possible to insert fontworks due to https://cgit.freedesktop.org/libreoffice/core/commit/?id=bf46b46a1d734348096936284fb8a76e977936d0. Before this commit, it doesn't crash...

Adding Cc: to Mohammed Abdul Azeem
Comment 4 Xisco Faulí 2018-09-03 09:27:57 UTC
Created attachment 144623 [details]
gdb backtrace
Comment 5 Sabri Unal 2018-10-30 17:05:22 UTC
I have encountered with this bug on 3 different Operating Systems.

Windows 10, LibreOffice 6.2.0.0.alpha1
Ubuntu 18.04, LibreOffice 6.2.0.0.alpha1
Ubuntu 18.10, LibreOffice 6.2.0.0.alpha1

http://crashreport.libreoffice.org/stats/crash_details/e8ea6282-ea7a-44c8-b7c5-cc963f029f3d
http://crashreport.libreoffice.org/stats/crash_details/1820b1c1-cd1f-47ba-a784-ed2174b015c2
Comment 6 Xisco Faulí 2018-10-30 20:07:38 UTC
@Michael Meeks, Do you know if Mohammed Abdul Azeem is still around in the project ?
Comment 7 Michael Meeks 2018-10-31 10:22:10 UTC
Only he can say - but I'll add this to my list of things to look at [ which is rather long =]
Comment 8 Michael Meeks 2018-11-02 17:08:46 UTC
Interesting - it seems to affect shapes that (from the README) use the old "xof" library built from the source/transform directory, which is the filter for the OpenOffice.org XML format.  This legacy format is a predecessor of ODF and was the default in OpenOffice.org 1.x versions, which did not support ODF.  This filter works as a SAX transformation from/to ODF, i.e., when importing a document the transform library reads the SAX events from the file and generates SAX events that are then consumed by the ODF import filter.

Interesting ... seems the component is: com.sun.star.comp.Draw.XMLImporter

warn:legacy.osl:32081:32081:sfx2/source/doc/sfxbasemodel.cxx:2800: SfxBaseModel::IsInitialized: this should have been caught earlier!
warn:xmloff.core:32081:32081:xmloff/source/core/xmlimp.cxx:1001: DBG_UNHANDLED_EXCEPTION in virtual void SvXMLImport::setTargetDocument(const uno::Reference<lang::XComponent> &)
    type: com.sun.star.lang.NotInitializedException
    context: SvxUnoDrawingModel
Comment 9 Michael Meeks 2018-11-02 19:16:51 UTC
Band aid in: https://gerrit.libreoffice.org/62789 - to kill the crash; but we don't get the import right - it is an older file and we have to use a rare path through the transformer here which uses the old parser code path.
Comment 10 Commit Notification 2018-11-08 06:12:36 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/f10b7e820844d94b4dbec3dcaf24392275940914%5E%21

tdf#119648 - even if we fail to import a fontwork, we shouldn't crash.

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2018-11-08 13:21:06 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/640ae4bf97530882614796aed669be8c4fd91fe4%5E%21

tdf#119648 - even if we fail to import a fontwork, we shouldn't crash.

It will be available in 6.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Xisco Faulí 2018-11-08 16:12:43 UTC
Verified in

Version: 6.2.0.0.alpha1+
Build ID: 1cfa1d9e1041b0e82d9be90847c428adfd01476e
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

@Michael Meeks, thanks for fixing this! Should it be closed as RESOLVED FIXED ?
Comment 13 Michael Meeks 2018-11-08 19:27:15 UTC
Lets re-title it - we still don't load those older style files right - there is some problem in the translation of old to new XML and implementation of the XFastParser pieces here that is annoying and needs fixing.
Comment 14 qscesz84563 2018-11-29 08:25:52 UTC
Bug not reproducible in
Version: 6.3.0.0.alpha0+ (x64)
Build ID: 0f25a3c36f27fd51453b9a9115f236b83c143684
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-27_20:06:55
Locale: zh-TW (zh_TW); UI-Language: en-US
Calc: threaded
Comment 15 Xisco Faulí 2018-12-26 13:01:28 UTC
(In reply to Michael Meeks from comment #13)
> Lets re-title it - we still don't load those older style files right - there
> is some problem in the translation of old to new XML and implementation of
> the XFastParser pieces here that is annoying and needs fixing.

Mohammed is working on that -> https://gerrit.libreoffice.org/#/c/63260/
Setting this one as VERIFIED FIXED