Download it now!
Bug 119693 - EDITING: UI - Incorrect buttons displayed during table data import (breeze)
Summary: EDITING: UI - Incorrect buttons displayed during table data import (breeze)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords: bibisected, bisected
: 124073 (view as bug list)
Depends on:
Blocks: Icon-Theme-Colibre
  Show dependency treegraph
 
Reported: 2018-09-04 12:47 UTC by John
Modified: 2019-04-05 14:54 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Icon difference between versions. (60.37 KB, image/png)
2018-09-05 17:39 UTC, John
Details
How it looks in master with elementary (23.36 KB, image/png)
2018-09-13 10:22 UTC, Xisco Faulí
Details
How it looks in master with Colibre (27.20 KB, image/png)
2018-09-13 10:25 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John 2018-09-04 12:47:54 UTC
When pasting data into an existing table in Base, the raise and lower icons in the "Assign Columns" dialog box are sort A->Z and sort Z->A icons.

To perform:
System: Windows 10, Libreoffice 6.1.0.3.
1) Create a table in Libreoffice Base
2) Copy data from Libreoffice Calc
3) Select the table from the LibreOffice Base main screen an choose "Paste" to bring up the Copy Table dialog box.
4) Select "Next" to see the dialog box with the error.
Comment 1 Xisco Faulí 2018-09-04 14:15:42 UTC
What error do you get?

I can't reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: bf8fbbaa683ef7eef5f9587b60486f622b50cb80
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

Setting to NEEDINFO
Comment 2 John 2018-09-05 16:31:22 UTC
Version: 6.2.0.0.alpha0+ is not available for Windows. The bug also exists in
Version: 6.1.1.1 (x64)
Build ID: 2718b4a18dfcc6a54ebe5f7b801ee7a47fa81e0c
CPU threads: 8; OS: Windows 10.0; UI render: default; 
Locale: en-US (en_US); Calc: group threaded
Comment 3 John 2018-09-05 16:53:51 UTC
I found the tinderbox for Libreoffice and can confirm the issue exists in:
Version: 6.2.0.0.alpha0+ (x64)
Build ID: efd316b6171b9e1827c5e34ddb12658f48268e24
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2018-09-05_11:26:52
Locale: en-US (en_US); Calc: CL
Comment 4 John 2018-09-05 17:39:28 UTC
Created attachment 144700 [details]
Icon difference between versions.

The buttons to raise and lower entries was replaced with sort A->Z and sort Z->A.
Comment 5 Xisco Faulí 2018-09-13 10:22:32 UTC
Created attachment 144831 [details]
How it looks in master with elementary
Comment 6 Xisco Faulí 2018-09-13 10:25:01 UTC
Created attachment 144832 [details]
How it looks in master with Colibre
Comment 7 andreas_k 2018-09-13 10:36:23 UTC
did someone know where the code of this icons are.
Comment 8 Xisco Faulí 2018-09-14 16:03:56 UTC
Same behaviour with Sifr icons...
Comment 9 Xisco Faulí 2018-09-14 16:32:14 UTC
I tried to bisect it for Sifr and it was correct until https://cgit.freedesktop.org/libreoffice/core/commit/?id=683cb8b9bd5dddfef6b64753bcaffd7d38d61a35 where it changed it fallback to breeze

Is Colibre's fallback breeze as well? that would explain this behaviour...
I believe the problem is in Breeze and it has been like this for quite some time...
Comment 10 Xisco Faulí 2018-09-14 16:35:46 UTC
This is the .UI dialog: https://opengrok.libreoffice.org/xref/core/dbaccess/uiconfig/ui/namematchingpage.ui
Comment 11 Heiko Tietze 2018-09-15 09:11:17 UTC
(In reply to Xisco Faulí from comment #9)
> Is Colibre's fallback breeze as well? 

Colibre is the ultimate fallback. Sifr_Dark falls back on Breeze_Dark, Sifr and Breeze_Dark on Breeze, anything else on Colibre, and Colibre itself on empty.

https://opengrok.libreoffice.org/xref/core/vcl/source/image/ImplImageTree.cxx#300
Comment 12 Robert Großkopf 2019-02-23 10:01:04 UTC
Got the same buggy behaviour with icon-theme Tango here. My system: OpenSUSE 15, 64bit rpm Linux. 

Bug first appears here in LO 6.1.0.3, doesn't appear in LO 6.0.5.2. So I set the version to  LO 6.1.0.3
Comment 13 Robert Großkopf 2019-03-14 16:14:08 UTC
*** Bug 124073 has been marked as a duplicate of this bug. ***
Comment 14 Robert Großkopf 2019-03-14 20:02:56 UTC
Why is the version set to LO 4.4? Bug does appear first with LO 6.1, see comment 12. The right buttons are shown in LO 6.0.5.2
Comment 15 Robert Großkopf 2019-03-14 20:12:11 UTC
Ok, have seen: It appears in Breeze earlier. Will set this bug back to LO 4.4

Will reopen the other bug I had seen as a duplicate.
Comment 16 Robert Großkopf 2019-04-05 14:39:52 UTC
*** Bug 124073 has been marked as a duplicate of this bug. ***
Comment 17 Commit Notification 2019-04-05 14:50:48 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/11590763e270c14dd6e03677a0cf23af9cfc98e2%5E%21

tdf#119693 base incorrect icon was show

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 andreas_k 2019-04-05 14:54:04 UTC
Patch submitted fixed everywhere excl. Tango.