Download it now!
Bug 119704 - EDITING CRASH: Freeze when pasting unformatted text while several elements of a bullet list are selected
Summary: EDITING CRASH: Freeze when pasting unformatted text while several elements of...
Status: RESOLVED DUPLICATE of bug 115438
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.6.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-04 22:59 UTC by toadjaune
Modified: 2018-09-05 07:28 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
steps 1 to 5 of reproduction steps (10.00 KB, application/vnd.oasis.opendocument.presentation)
2018-09-04 22:59 UTC, toadjaune
Details

Note You need to log in before you can comment on or make changes to this bug.
Description toadjaune 2018-09-04 22:59:40 UTC
Created attachment 144682 [details]
steps 1 to 5 of reproduction steps

### System information

OS : Fedora 28
package : libreoffice-impress.x86_64 1:6.0.6.2-1.fc28 (official Fedora package)

So far, haven't tested any other OS/version

### Reproduction steps

The attached file contains the steps 1 to 5

1) Open a new Impress presentation
2) Create two text zones (let's call them A and B)
3) Type some text in zone A
4) Insert a bullet list in zone B (Format > Bullets and Numbering… > Ok)
5) Add some text in zone B, with at least 2 list elements
6) Select all the text in zone A
7) Copy it (Ctrl-C)
8) Select all the text in zone B (spanning over several bullet list elements)
9) Paste as unformatted text (Ctrl-Shift-V > unformatted text > Ok)

From there, the whole program becomes unresponsive (even the last Ok button visually remains pressed), while the LibreOffice process uses 100% of a CPU core until killed.


Possibly related to https://bugs.documentfoundation.org/show_bug.cgi?id=119169
Comment 1 Xisco Faulí 2018-09-05 07:28:49 UTC
Thanks for reporting the issue.
I think this is a dupe of bug 115438 and it should be fixed in the upcoming LibreOffice 6.1.1.2
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 115438 ***