Bug 119705 - PNG: image with transparent background copied from Firefox/Chrome is pasted with black background
Summary: PNG: image with transparent background copied from Firefox/Chrome is pasted w...
Status: RESOLVED DUPLICATE of bug 98275
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Images
  Show dependency treegraph
 
Reported: 2018-09-05 02:03 UTC by perie_gut
Modified: 2019-03-18 19:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screendshots (134.06 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-09-05 02:03 UTC, perie_gut
Details

Note You need to log in before you can comment on or make changes to this bug.
Description perie_gut 2018-09-05 02:03:19 UTC
Created attachment 144685 [details]
screendshots

source> Copy > Paste (image)     ----> image had a black background

source > download > Insert > Image  ----> image had a transparent background 

expected result is to have a transparent background
Comment 1 Xisco Faulí 2018-09-05 11:09:49 UTC
Could you please share the source of the picture?
Setting to NEEDINFO until the information is provided!
Comment 2 Regina Henschel 2018-09-05 12:24:36 UTC
And please say, which application you use to show the image, when you do copy&paste. The image uses 32bit, which means it uses transparency via alpha-channel. It might happen, that the application from where you copy&paste is not able to put the image in 32bit version into the clipboard and only provides a 24bit version.
Comment 3 perie_gut 2018-09-07 03:41:59 UTC
for the sample image kindly use this link 
https://cdn2.iconfinder.com/data/icons/perfect-flat-icons-2/512/Printer_print_3d_vector_symbol_simple_pictogram.png

however you can use any images from different locations as long as the image has no background or transparent. 

for the application, this behaviour only occur in CALC and DRAW. Writer was able to have a uniform behaviour
Comment 4 perie_gut 2018-09-07 03:43:09 UTC
(In reply to Regina Henschel from comment #2)
> And please say, which application you use to show the image, when you do
> copy&paste. The image uses 32bit, which means it uses transparency via
> alpha-channel. It might happen, that the application from where you
> copy&paste is not able to put the image in 32bit version into the clipboard
> and only provides a 24bit version.

the image was copied directly to the browser (on my case firefox 62)
Comment 5 Xisco Faulí 2018-09-13 10:52:13 UTC
oh, this is interesting.

First time I paste the image from Firefox it has a transparent background, the second time it's completely black

Reproduced in

Version: 6.2.0.0.alpha0+
Build ID: aaa3c31ba79b1b3d335dcf55d72837a13411b45e
CPU threads: 16; OS: Windows 6.3; UI render: default; 
Locale: en-GB (en_GB); Calc: threaded

and

Versión: 6.1.0.3
Id. de compilación: efb621ed25068d70781dc026f7e9c5187a4decd1
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threaded

and

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

with Chrome, it's reproducible on the first copy.
Tested with two different computers and not reproducible if pasted to MSO 2010

OTOH, it's not reproducible on Linux
It's likely it has been already reported, but I can't find it. Putting to NEW for the time being...
Comment 6 Julien Nabet 2019-03-15 12:21:02 UTC
Dup of 98275 ?
Comment 7 Xisco Faulí 2019-03-18 19:18:13 UTC
(In reply to Julien Nabet from comment #6)
> Dup of 98275 ?

yep, it seems so. Thanks for pinpointing it

*** This bug has been marked as a duplicate of bug 98275 ***