Bug Hunting Session
Bug 119731 - Calc: Not Suitable Group and Ungroup Icon Representation
Summary: Calc: Not Suitable Group and Ungroup Icon Representation
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords:
Depends on:
Blocks: UNO-Command-New Icon-Themes
  Show dependency treegraph
 
Reported: 2018-09-06 16:11 UTC by Rizal Muttaqin
Modified: 2018-11-03 18:38 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Calc Group and Ungroup icons (46.36 KB, image/png)
2018-09-06 16:13 UTC, Rizal Muttaqin
Details
MS Excel Group and Ungroup icons (44.74 KB, image/jpeg)
2018-09-06 16:14 UTC, Rizal Muttaqin
Details
These icons are my proposal for Calc's Group and Ungroup function (3.60 KB, image/png)
2018-09-08 04:07 UTC, Rizal Muttaqin
Details
Group icon in Draw (196.75 KB, image/png)
2018-10-27 08:21 UTC, Rizal Muttaqin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rizal Muttaqin 2018-09-06 16:11:38 UTC
Description:
As we know Calc has a feature to simplify outline view with Group and Ungroup. Unfortunately, current icon implementation of these two functions are misleading. They are using same icon with other module that represent action with "shape" instead of "cell".  

There's no specific :uno command for these icons so it seems we should hard code to change, not just changing the icon.

Steps to Reproduce:
1. Open Calc 
2. Navigate to Data menu > Group and Outline > [Group...] or [Ungroup...]

Actual Results:
Calc's Group and Ungroup icon use wrong icon representation

Expected Results:
Calc's Group and Group use proper icons


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Rizal Muttaqin 2018-09-06 16:13:19 UTC
Created attachment 144719 [details]
Calc Group and Ungroup icons
Comment 2 Rizal Muttaqin 2018-09-06 16:14:35 UTC
Created attachment 144720 [details]
MS Excel Group and Ungroup icons

We can see Excel as a comparison. The icons fits perfectly
Comment 3 Rizal Muttaqin 2018-09-08 04:07:51 UTC
Created attachment 144748 [details]
These icons are my proposal for Calc's Group and Ungroup function
Comment 4 Pedro 2018-10-21 19:02:28 UTC
This should be fixed before the Notebookbar is officially released. 
As it is now, the icons do not represent what Group and Ungroup do in Calc. Could someone split the.uno commands please?
Comment 5 Heiko Tietze 2018-10-26 09:12:13 UTC
(In reply to Pedro from comment #4)
> Could someone split the.uno commands please?

Maxim, do you think this proposal makes sense?
Comment 6 Maxim Monastirsky 2018-10-26 12:49:36 UTC
(In reply to Heiko Tietze from comment #5)
> Maxim, do you think this proposal makes sense?
Outline group command is .uno:Group (and isn't used outside Calc). Shape group command is .uno:FormatGroup. They are separate commands already.
Comment 7 Heiko Tietze 2018-10-26 14:34:19 UTC
(In reply to Maxim Monastirsky from comment #6)
> (In reply to Heiko Tietze from comment #5)
> > Maxim, do you think this proposal makes sense?
> Outline group command is .uno:Group (and isn't used outside Calc). Shape
> group command is .uno:FormatGroup. They are separate commands already.

So we can close this ticket as WFM/FIXED?
Comment 8 Rizal Muttaqin 2018-10-27 08:21:12 UTC
Created attachment 146052 [details]
Group icon in Draw

(In reply to Maxim Monastirsky from comment #6)
>Outline group command is .uno:Group (and isn't used outside Calc). Shape group >command is .uno:FormatGroup. They are separate commands already.

I don't think so. After splitting them, the .uno:Group and .uno:Ungroup are being used also in another module. I don't find the .uno:FormatGroup .uno:FormatUngroup usage.

This attachment show use group icon in Draw's shape right click menu
Comment 9 Maxim Monastirsky 2018-10-27 18:24:09 UTC
(In reply to Rizal Muttaqin from comment #8)
> I don't think so. After splitting them, the .uno:Group and .uno:Ungroup are
> being used also in another module.
Did you look at the links.txt files for various icon themes? There seems to be some themes that link cmd/sc_formatgroup.png to cmd/sc_group.png etc. That might be the issue.
Comment 10 andreas_k 2018-10-27 19:26:37 UTC
This is a todo bug to fix the icons in all icon themes, so no code stuff needed.
Comment 11 Rizal Muttaqin 2018-10-27 19:48:36 UTC
(In reply to Maxim Monastirsky from comment #9)
> (In reply to Rizal Muttaqin from comment #8)
> > I don't think so. After splitting them, the .uno:Group and .uno:Ungroup are
> > being used also in another module.
> Did you look at the links.txt files for various icon themes? There seems to
> be some themes that link cmd/sc_formatgroup.png to cmd/sc_group.png etc.
> That might be the issue.

I already know. I've splitted them by removing the line in links.txt and then renamed sc_group.png to sc_formatgroup.png lastly created a new sc_group.png file. The result is that other modules other than Calc use sc_group file instead.
Comment 12 Rizal Muttaqin 2018-10-27 20:00:28 UTC
(In reply to Rizal Muttaqin from comment #11)
> (In reply to Maxim Monastirsky from comment #9)
> > (In reply to Rizal Muttaqin from comment #8)
> > > I don't think so. After splitting them, the .uno:Group and .uno:Ungroup are
> > > being used also in another module.
> > Did you look at the links.txt files for various icon themes? There seems to
> > be some themes that link cmd/sc_formatgroup.png to cmd/sc_group.png etc.
> > That might be the issue.
> 
> I already know. I've splitted them by removing the line in links.txt and
> then renamed sc_group.png to sc_formatgroup.png lastly created a new
> sc_group.png file. The result is that other modules other than Calc use
> sc_group file instead.

So sorry, my fault. There is more than one formatgroup.png to group.png line declaration in elementary links.txt file. So, you are right Maxim. Everything is fine. I think we can close this bug?
Comment 13 Commit Notification 2018-10-27 20:22:03 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d666b6b19d3e400561edc585d967ecab266c6b8f

elementary: fix for tdf#120831 & tdf#120300, related to tdf#119731, etc

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2018-10-28 13:09:39 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5aaa7282582efd5b6c88e6d76cbd0d8b460ab19a

elementary: Refix for tdf#119731, update presentation/slide related icons, add envelope, etc

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2018-11-03 18:38:19 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/fd03b130525b9d7683c14939f6eec36895031930%5E%21

KJ: Fix for tdf#120300, tdf#120831, tdf#119731, tdf#111950 add Calc's sheet context menu, etc

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.