Bug Hunting Session
Bug 119754 - Save as & PDF export no longer uses current doc location as starting point
Summary: Save as & PDF export no longer uses current doc location as starting point
Status: RESOLVED DUPLICATE of bug 119133
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-08 05:09 UTC by putt1ck
Modified: 2018-09-18 13:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description putt1ck 2018-09-08 05:09:10 UTC
Since v6.05 or close, document "save as" and PDF export fail to use current doc location as the starting point, reverting to user home directory as a starting point. 

I noticed this change ~2 months ago, but put it down to a blip as I use Tumbleweed. However it has persisted through several update cycles and is still present in LO 6.1.0.3. Cannot confirm which version the bug arrived in but see comment linked below referencing 6.0.5; this matches, give or take, the release history of LibreOffice in Tumbleweed i.e. I'd look there for the regression.

https://ask.libreoffice.org/en/question/37405/make-libreoffice-remember-last-default-location/

Also seems related to recent comments on

https://bugs.documentfoundation.org/show_bug.cgi?id=34303
Comment 1 V Stuart Foote 2018-09-08 06:56:09 UTC
The problem is in that DE integration.

On Windows builds it still works correctly if you force use of the LO file dialog rather than the system file dialog supported by the projects VistaFilePickerImpl, which has long had problems as in bug 34303 and bug 37814 

But the setting was moved from Tools -> Options -> General to a Expert Configuration stanza. Search for "UseSystemFileDialog"

Please retest using the LO file dialog rather than your distro's to see if the problem is likewise with the DE support of your distro.

=-testing-=

On Windows 10 Pro 64-bit en-US (1803) with
Version: 6.2.0.0.alpha0+ (x64)
Build ID: 9a9b81c7212fa6a6762246593acf3f1950677a22
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-09-07_23:40:38
Locale: en-US (en_US); Calc: threaded
Comment 2 David 2018-09-08 18:35:28 UTC
In Linux, using LO version 6.1 with "Use LibreOffice dialogs" enabled I notice the regression when exporting a database report but not when exporting a word processing or spreadsheet document.
Comment 3 putt1ck 2018-09-09 04:44:28 UTC
Concur the issuw I reported is not in the LO native file save box. But:

this is the first time in some years I've seen that native file save box;
the issue did not exist using the DE (Plasma 5) file save before ~6.05;
the issue is affecting more than one DE.

So do we assume the bug is in the API used by the DEs?
Comment 4 Maxim Monastirsky 2018-09-09 06:38:13 UTC
Please take a look at the info under Help > About LibreOffice. If it says "VCL: gtk3_kde5" then it's likely a duplicate of Bug 119133, and should be fixed for 6.1.1.
Comment 5 putt1ck 2018-09-09 07:19:24 UTC
(In reply to Maxim Monastirsky from comment #4)
> Please take a look at the info under Help > About LibreOffice. If it says
> "VCL: gtk3_kde5" then it's likely a duplicate of Bug 119133, and should be
> fixed for 6.1.1.

Yes, that sounds like the fix I'm after. I should have got around to reporting it sooner and then a fix might have been released already!
Comment 6 Xisco Faulí 2018-09-13 10:56:25 UTC
(In reply to putt1ck from comment #5)
> (In reply to Maxim Monastirsky from comment #4)
> > Please take a look at the info under Help > About LibreOffice. If it says
> > "VCL: gtk3_kde5" then it's likely a duplicate of Bug 119133, and should be
> > fixed for 6.1.1.
> 
> Yes, that sounds like the fix I'm after. I should have got around to
> reporting it sooner and then a fix might have been released already!

Closing as DUPLICATED then. LibreOffice 6.1.1 will be released in an hour. Please test it again with the latest version to verify it's indeed fixed.
Thanks

*** This bug has been marked as a duplicate of bug 119133 ***