Bug 119795 - crash when inserting a measure line
Summary: crash when inserting a measure line
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: x86-64 (AMD64) All
: highest critical
Assignee: Armin Le Grand
URL:
Whiteboard:
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2018-09-10 22:30 UTC by Regina Henschel
Modified: 2018-09-17 09:10 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
call stack as reported by Visual Studio (3.79 KB, text/plain)
2018-09-10 22:30 UTC, Regina Henschel
Details
gdb bt (8.64 KB, text/plain)
2018-09-11 19:13 UTC, Julien Nabet
Details
Valgrind trace (11.43 KB, application/gzip)
2018-09-11 20:14 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2018-09-10 22:30:52 UTC
Created attachment 144777 [details]
call stack as reported by Visual Studio

Start Draw.
Select the "measure line" tool from the "Line and Arrows" sub-toolbar.
Draw a measure line -> crash.

Error message is
Ausnahme ausgelöst bei 0x00007FFF9B2E6360 (editenglo.dll) in soffice.bin: 0xC0000005: Zugriffsverletzung beim Lesen an Position 0x0000000000000080.

No crash report.

It happens in Version: 6.2.0.0.alpha0+ (x64)
Build-ID: a201c5c8c3e7ea14001b5634f330dbce2b1f4314
CPU-Threads: 8; BS: Windows 10.0; UI-Render: GL; 
Gebietsschema: de-DE (en_US); Calc: CL

and too in Version: 6.2.0.0.alpha0+ (x64)
Build ID: efe119aaa50e9f532b3fac1ef153469c80f24b80
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-09-10_01:36:26
Locale: de-DE (en_US); Calc: CL

The call stack from Visual Studio is attached.
Comment 1 Regina Henschel 2018-09-10 22:55:03 UTC
It is OK in Version: 6.2.0.0.alpha0+
Build ID: d59acca8d1e33585d6f29cd85e8cb0d598067f9b
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-09-02_04:28:44
Locale: en-US (en_US); Calc: CL

and crashed in Version: 6.2.0.0.alpha0+
Build ID: 5a4ed4533127db8cf149353d587a7d3a89c5b338
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-09-03_12:13:14
Locale: en-US (en_US); Calc: CL
Comment 2 Drew Jensen 2018-09-11 00:14:20 UTC
Confirmed Ubuntu 18.04 Libreoffice
Version: 6.2.0.0.alpha0+
Build ID: 2789bbfd607240f260dfb38b6e9c19c9cf49fca9
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-09-09_22:35:03
Comment 3 Xisco Faulí 2018-09-11 07:50:35 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=7b52990a234bfd6d4efcbc9fe51e240e065faeea

author	Paul Trojahn <paul.trojahn@gmail.com>	2018-08-19 09:18:28 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2018-08-26 10:08:06 +0200
commit	7b52990a234bfd6d4efcbc9fe51e240e065faeea (patch)
tree	3b382c05febcb0a0fdcded0b1a8b5e0fd6af9873
parent	7a115715c7884d43ed7a4ff9054fed9a95cefef0 (diff)
tdf#106260 Fix invisible pasted urls
UpdateFields() was never called after pasting a field.

Bisected with: bibisect-linux64-6.2

Adding Cc: to Paul Trojahn

Increasing severity as the commit has been backported to branch 6.1
Comment 4 Julien Nabet 2018-09-11 19:13:01 UTC
Created attachment 144804 [details]
gdb bt

On pc Debian x86-64 with master sources updated, I could reproduce this.
Comment 5 Julien Nabet 2018-09-11 20:14:07 UTC
Created attachment 144805 [details]
Valgrind trace
Comment 6 Julien Nabet 2018-09-11 20:40:04 UTC
Xisco: IMHO the commit you quote seems more an element which reveals the bug than the root cause of the bug.
Of course, it's just an hypothesis, I'm not sure at all.
Comment 7 Xisco Faulí 2018-09-13 13:55:56 UTC
(In reply to Julien Nabet from comment #6)
> Xisco: IMHO the commit you quote seems more an element which reveals the bug
> than the root cause of the bug.
> Of course, it's just an hypothesis, I'm not sure at all.

Most likely.
@Paul Trojahn, what do you think ?
Comment 8 Julien Nabet 2018-09-16 13:32:07 UTC
Just for information, I don't reproduce the crash with Armin's patch https://gerrit.libreoffice.org/#/c/60546/ on gerrit review for the moment.
Comment 9 Julien Nabet 2018-09-16 19:13:31 UTC
Fixed with https://cgit.freedesktop.org/libreoffice/core/commit/?id=d357e50fa1734da0bf341dbd49fc0596011bdfe3
(at least, on pc Debian x86-64 with master sources updated today + enable-dbgutil + gtk3, I don't reproduce this one anymore)

If someone still reproduces this with the quoted commit, don't hesitate to reopen this tracker.
Paul: also don't hesitate to reassign it to yourself if it can be still reproduced and still want to work on it.
Comment 10 Xisco Faulí 2018-09-17 09:10:48 UTC
(In reply to Julien Nabet from comment #9)
> Fixed with
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=d357e50fa1734da0bf341dbd49fc0596011bdfe3
> (at least, on pc Debian x86-64 with master sources updated today +
> enable-dbgutil + gtk3, I don't reproduce this one anymore)

I do confirm the issue is fixed by the mentioned commit

Verified in

Version: 6.2.0.0.alpha0+
Build ID: 2419fa71d8b2223a50f596d5db7721f6213d4f87
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded