Bug 119797 - The table is make libreoffice draw very very slow
Summary: The table is make libreoffice draw very very slow
Status: RESOLVED DUPLICATE of bug 119340
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-09-11 00:47 UTC by cgpanda
Modified: 2018-09-11 19:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
it's a draw file, in page 7 have a table, and slow at there (111.15 KB, application/vnd.oasis.opendocument.graphics)
2018-09-11 00:49 UTC, cgpanda
Details
On Linux it is not slow. See the video (4.23 MB, video/mp4)
2018-09-11 01:09 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cgpanda 2018-09-11 00:47:13 UTC
Description:
Hi, The table will make libreoffice slowly, very slow. I think it's have problem, just a simple table.

Steps to Reproduce:
1.just open my file, and view the page 7, there have a table
2.
3.

Actual Results:
so slow, what ever you doing anything, zoom or edit, all very slow

Expected Results:
I think it should smooth


Reproducible: Always


User Profile Reset: No



Additional Info:
I am first report bug for libeoffice, and sorry my bad english.
Comment 1 cgpanda 2018-09-11 00:49:40 UTC
Created attachment 144778 [details]
it's a draw file, in page 7 have a table, and slow at there

it's a draw file, in page 7 have a table, and slow at there
Comment 2 BogdanB 2018-09-11 01:09:03 UTC
Created attachment 144779 [details]
On Linux it is not slow. See the video

I can't reproduce on Linux on 6.0, 6.1 or 6.2

In this video you can see it is working very well in all 3 versions. On linux.
Comment 3 cgpanda 2018-09-11 01:32:11 UTC
I am in windows, and have test in three computer, 5.4x work will, 6.x slow.
Comment 4 BogdanB 2018-09-11 01:40:17 UTC
For 6.x try User Profile Reset.
https://wiki.documentfoundation.org/UserProfile#Resolving_corruption_in_the_user_profile
Comment 5 cgpanda 2018-09-11 01:56:19 UTC
Thanks for your tip, I have delete the config files, but still, and only in 6.x in windows, win10 and win8.

I dont know where to upload the video, you can find at here:
https://www66.zippyshare.com/v/OMwJeBEX/file.html

thanks
Comment 6 BogdanB 2018-09-11 06:38:52 UTC
I tested now on windows. I can reproduce on 6.1.0.3 but NOT on 6.2.
It seems it is solved on 6.2

Version: 6.1.0.3 (x64)
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: ro-RO (ro_RO); Calc: group threaded

Version: 6.2.0.0.alpha0+ (x64)
Build ID: efd316b6171b9e1827c5e34ddb12658f48268e24
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2018-09-05_11:26:52
Locale: ro-RO (ro_RO); Calc: threaded
Comment 7 Telesto 2018-09-11 09:36:56 UTC
Setting to NEW for the moment. The big question: is this also reproducible with LibO 6.1.1
Comment 8 BogdanB 2018-09-11 11:34:51 UTC
I can reproduce on

Version: 6.1.1.1 (x64)
Build ID: 2718b4a18dfcc6a54ebe5f7b801ee7a47fa81e0c
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: ro-RO (ro_RO); Calc: group threaded
Comment 9 cgpanda 2018-09-11 12:18:40 UTC
Very thanks for you, I can't believe have people in here and care. hope libreoffice will be better for windows users. thanks;
Comment 10 BogdanB 2018-09-11 18:01:31 UTC
I bibisect 6.1 on linux. Not a problem at all. It seems a windows specific bug.
Comment 11 BogdanB 2018-09-11 18:17:10 UTC
I bibisect also 6.0 on linux. Not a problem at all. Windows specific bug.
Comment 12 Xisco Faulí 2018-09-11 19:32:40 UTC
Issue fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=7e7a1ff3926e86705199aa9814089e90f01c02ed which is only in 6.2 for the time being...
Closing as duplicated of bug 119340

*** This bug has been marked as a duplicate of bug 119340 ***