Download it now!
Bug 119816 - Scanner (Acer-Benq 620U) not recognized by Libreoffice 6.1.0.3 (on W10 64 bits, yes)
Summary: Scanner (Acer-Benq 620U) not recognized by Libreoffice 6.1.0.3 (on W10 64 bit...
Status: RESOLVED DUPLICATE of bug 105762
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-12 09:50 UTC by Ricardo
Modified: 2018-09-13 14:48 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ricardo 2018-09-12 09:50:43 UTC
Description:
When I go to menu: insert -> multimedia -> scan or select (apply for) Libreoffice doesn´t found driver (x64) for scaner Acer (Benq) 620U.
This problem was reported for the previous version (5.x) and theoretically it should have been resolved in version 6.1.

Steps to Reproduce:
1.Install scanner in W10 64 bits with drivers not signed (acer64) and turn on.
2.Install and open Libreoffice 6.1.0.3
3.Got to menu : insert -> multimedia -> select or scan.

Actual Results:
See previous question.

Expected Results:
Scanner doesn´t exist for Libreoffice, but for others programs in windows.


Reproducible: Always


User Profile Reset: No



Additional Info:
See Scanner, select it and scan.
-----------------------------------
-----------------------------------
File acerscan.inf in windows :
---------------------------------
;
; ACERSCAN.INF  -- Windows Still Image Setup File
;
; Copyright (c) Microsoft Corporation.  All rights reserved.
; Manufacturer: Microsoft Corp for Acer
[Version]
LayoutFile=Layout.inf
Signature="$Windows NT$"
Class=Image
ClassGUID={6bdd1fc6-810f-11d0-bec7-08002be2092f}
Provider="Microsoft"
DriverVer=12/24/2012,5.2.3790.1830
CatalogFile=acerscan.cat

[SourceDisksNames]
1 = "disk"

[SourceDisksFiles]
AcerScaD.dll = 1
Model.ini = 1
u96v121.bin = 1
u34v110.bin = 1
u64v119.bin = 1
u126v041.bin = 1
u190v041.bin = 1
u192v073.bin = 1
u222V065.bin = 1
u176v040.bin = 1


[Manufacturer]
"Microsoft"=Microsoft,NTx86,NTAMD64,NTIA64,NTARM

[ControlFlags]
ExcludeFromSelect=*

[DestinationDirs]
DefaultDestDir=11
WIA.ScanUsd=10,system32
WIA.FirmWare=10,usbbin

[Manufacturer]
%Mfg%=Models,NTamd64

[Models.NTamd64]
%FlatbedScaner5%=WIA.Scanner,USB\VID_04A5&PID_1A20
%FlatbedScaner5%=WIA.Scanner,USB\VID_04A5&PID_1A2A
%FlatbedScaner13%=WIA.Scanner,USB\VID_04A5&PID_2022
%FlatbedScaner13%=WIA.Scanner,USB\VID_04A5&PID_2060
%FlatbedScaner16%=WIA.Scanner,USB\VID_04A5&PID_2040
%FlatbedScaner19%=WIA.Scanner,USB\VID_04A5&PID_20C0
%FlatbedScaner20%=WIA.Scanner,USB\VID_04A5&PID_207E
%FlatbedScaner20%=WIA.Scanner,USB\VID_04A5&PID_20BE
%FlatbedScaner21%=WIA.Scanner,USB\VID_04A5&PID_20DE
%FlatbedScaner23%=WIA.Scanner,USB\VID_04A5&PID_20B0

[WIA.Scanner]
Include = sti.inf
Needs   = STI.USBSection

SubClass=StillImage
DeviceType=1
DeviceSubType=0x1
Capabilities=0x31
Events=WIA.Events
DeviceData=WIA.DeviceData
AddReg=WIA.AddReg
CopyFiles=WIA.ScanUsd,WIA.Firmware
ICMProfiles="sRGB Color Space Profile.icm"

[WIA.Events]
Button1_0=%Button1_0%,{7AD6EA4C-3AAB-11d3-86CB-08002BE4D8DC},*
Button1_1=%Button1_1%,{76B1B8A1-394D-11d3-86CB-08002BE4D8DC},*
Button2_0=%Button2_0%,{76B1B8A2-394D-11d3-86CB-08002BE4D8DC},*
Button2_1=%Button2_1%,{76B1B8B9-394D-11d3-86CB-08002BE4D8DC},*
Button3_0=%Button3_0%,{76B1B8BA-394D-11d3-86CB-08002BE4D8DC},*
Button3_1=%Button3_1%,{76B1B8BD-394D-11d3-86CB-08002BE4D8DC},*


[WIA.Scanner.Services]
Include =    sti.inf
Needs   = STI.USBSection.Services

[WIA.DeviceData]
Server=local

[WIA.AddReg]
HKR,,HardwareConfig,1,1
HKR,,DevLoader,,*NTKERN
HKR,,NTMPDriver,,"usbscan.sys"
HKR,,USDClass,,"{5D922427-8843-11d1-B882-08002BE4EC98}"
HKCR,CLSID\{5D922427-8843-11d1-B882-08002BE4EC98},,,"Acer USB User MiniDriver"
HKCR,CLSID\{5D922427-8843-11d1-B882-08002BE4EC98}\InProcServer32,,,%10%\system32\AcerScaD.dll
HKCR,CLSID\{5D922427-8843-11d1-B882-08002BE4EC98}\InProcServer32,ThreadingModel,,"Both"

[WIA.ScanUsd]
AcerScaD.dll

[WIA.Firmware]
Model.ini
u96v121.bin
u34v110.bin
u64v119.bin
u126v041.bin
u190v041.bin
u192v073.bin
u222V065.bin
u176v040.bin


[Strings]
Msft="Microsoft"
Mfg="Acer Peripherals,Inc."

FlatbedScaner5 ="Acer 310U/620U"
FlatbedScaner13="Acer 320U/340U/620U+/640U"
FlatbedScaner16="Acer 620UT+/640UT"
FlatbedScaner19="Acer 1240UT/5100U"
FlatbedScaner20="Acer 640BT/640BU"
FlatbedScaner21="Acer 4300U/3300U"
FlatbedScaner23="Acer 4300U/3300U"

Button1_0="Preview"
Button1_1="Scan to file"
Button2_0="OCR"
Button2_1="E-Mail"
Button3_0="Copy"
Button3_1="Fax"

----------------------------------------
----------------------------------------
Comment 1 Xisco Faulí 2018-09-13 09:19:53 UTC
You can't confirm your own bugs. Moving it back to UNCONFIRMED until someone
else confirms it.

@Mike Kaganski, I thought you could be interested in this issue...
Comment 2 V Stuart Foote 2018-09-13 14:48:45 UTC
We have no support for 32-bit or 64-bit WIA and associated driver(s)--that is bug 105762. Rather we remain dependent on TWAIN support--and hence on a 64-bit TWAIN driver.

So, on this manufacturer deprecated '90s hardware (BenQ does not support it in current TWAIN or WIA) the only choice is a 3rd party implementation of 64-bit TWAIN. 

We've found that Hamrick Software VueScan drivers provide the useful 64-bit TWAIN support we need.

*** This bug has been marked as a duplicate of bug 105762 ***