Bug Hunting Session
Bug 119822 - Crash in: GetFrameOfModify(SwRootFrame const *,SwModify const &,SwFrameType,Point const *,SwPosition const *,bool)
Summary: Crash in: GetFrameOfModify(SwRootFrame const *,SwModify const &,SwFrameType,P...
Status: RESOLVED DUPLICATE of bug 109376
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-09-12 14:20 UTC by Thomas Lendo
Modified: 2018-11-14 13:44 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["GetFrameOfModify(SwRootFrame const *,SwModify const &,SwFrameType,Point const *,SwPosition const *,bool)"]


Attachments
BT without symbols (5.70 KB, text/plain)
2018-10-03 15:37 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2018-09-12 14:20:52 UTC
This bug was filed from the crash reporting server and is br-947ab50d-1025-4135-8d4c-812919c2e59b.

Similar crashes available at http://crashreport.libreoffice.org/stats/signature/GetFrameOfModify(SwRootFrame%20const%20*,SwModify%20const%20&,SwFrameType,Point%20const%20*,SwPosition%20const%20*,bool)
=========================================

I noticed a recurring crash when comparing a Writer document with a similar Writer document.

I can't attach the documents to the bug because they are machine instructions with about 40 pages each, containing text, headings, pictures and tables--nothing special according to my opinion. I can send it to someone who is willing to test privately and secretly.

The crashes occur after some time viewing the documents or after clicking at 'Accept all' or 'Reject all' in the Manage Changes dialog window.


Tested today with

Version: 6.0.4.2 (x64)
Build-ID: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
CPU-Threads: 8; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-AT (de_AT); Calc: group

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 414ef6cb187dd3bbcc917dbedf3c0c1cc8668f60
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-08-21_00:13:04
Locale: de-AT (de_AT); Calc: CL

These crashes on LibO 6.2 don't initiate a crash report on my computer.
Comment 1 Xisco Faulí 2018-09-12 14:32:15 UTC
Hi Thomas,
Could you please send the document to me privately ?
Thanks
Comment 2 Xisco Faulí 2018-09-12 15:19:09 UTC
Hi Thomas,
Thanks for sharing the document with me
I suppose you do:
1. Open one of the documents
2. Go to Edit - Track Changes - Compare Documents and you select the second document.

I can't reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: 2aaf5a73dac9f1dc137fba1e5f8536ef9f67ed89
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

nor in

Versión: 6.1.0.3
Id. de compilación: efb621ed25068d70781dc026f7e9c5187a4decd1
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threaded

it seems you're using an old version of LibreOffice.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 3 Thomas Lendo 2018-09-13 15:12:35 UTC
Hm, today no crashes here.

Tested with 6.2.0.0.alpha0+ (2018-09-12_23:24:12), 6.1.1.2, 6.0.4.2.

I close this bug as WFM and will reopen it if I've new insights.

But it's alarming that there are so many crashes reported.
Comment 4 Thomas Lendo 2018-09-13 15:15:01 UTC
If somebody has such crashes too, please reopen this bug as UNCONFIRMED and attach a sample document.
Comment 5 Thomas Lendo 2018-09-17 12:26:24 UTC
REOPENING the bug as today--after about 15 minutes of being in the background--an odt document crashed LibreOffice when comparing with a similar document.

Maybe someone can reproduce it sometime. There are so many crash reports that I think it's worth to keep the bug open.
Comment 6 Telesto 2018-09-25 18:21:28 UTC
(In reply to Thomas Lendo from comment #5)
> REOPENING the bug as today--after about 15 minutes of being in the
> background--an odt document crashed LibreOffice when comparing with a
> similar document.
> 
> Maybe someone can reproduce it sometime. There are so many crash reports
> that I think it's worth to keep the bug open.

Can you still reproduce the crash with the initial document (comment 0)? I would love to check it out.
Comment 7 Thomas Lendo 2018-10-03 13:05:14 UTC
(In reply to Telesto from comment #6)
> Can you still reproduce the crash with the initial document (comment 0)? I
> would love to check it out.
Hi Telesto, I still can reproduce the crash after clicking at 'Accept all' or 'Reject all' in the Manage Changes dialog window.

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 89a60912bba7ffd6f65ea99f4664f343c5025c95
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-01_03:18:33
Locale: de-AT (de_AT); Calc: CL

I can mail you the 2 documents if you want.
Comment 8 Telesto 2018-10-03 13:22:16 UTC Comment hidden (obsolete)
Comment 9 Telesto 2018-10-03 15:37:37 UTC
Created attachment 145349 [details]
BT without symbols

Repro with
Version: 6.2.0.0.alpha0+
Build ID: 52cb73911e661fb636085337374e09845f07783b
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-10-02_01:05:50
Locale: nl-NL (nl_NL); Calc: CL

and with
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL

but not with
Version: 4.3.7.2
Build ID: 8a35821d8636a03b8bf4e15b48f59794652c68ba
Comment 10 Telesto 2018-10-03 15:39:17 UTC
STR
1. Open one of the documents
2. Go to Edit - Track Changes - Compare Documents and you select the second document.
3. Click 'Accept all' or 'Reject all'
Comment 11 Thomas Lendo 2018-10-04 22:58:15 UTC
Thanks for your test and BT, Telesto!
Comment 12 Telesto 2018-10-05 18:42:23 UTC
@Michael
I thought you might be interested in this one based on all the redline refactoring. Documents in question are shared privately..
Comment 13 Xisco Faulí 2018-11-14 12:47:49 UTC
oh, I just realized the documents Thomas Lendo sent me are pretty much the same as in bug 109376.
Closing as a duplicated

*** This bug has been marked as a duplicate of bug 109376 ***
Comment 14 Xisco Faulí 2018-11-14 13:16:26 UTC
I do confirm this started to crash after https://cgit.freedesktop.org/libreoffice/core/commit/?id=e07feb9457f2ffb373ae69b73dda290140e4005f, so let's follow up on bug 109376 as we have the documents to reproduce it
Comment 15 Xisco Faulí 2018-11-14 13:42:40 UTC
@Thomas Lendo, the original crash signature you reported can be reproduced following bug 98868