Download it now!
Bug 119832 - Animated Gif's Cause Libreoffice Impress to Hang / Crash / Become Very Unstable Under Windows 7 / 10
Summary: Animated Gif's Cause Libreoffice Impress to Hang / Crash / Become Very Unstab...
Status: RESOLVED DUPLICATE of bug 104878
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-13 02:12 UTC by rickpress
Modified: 2018-10-05 16:44 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Animated Gif that can cause a crash / slow down (863.43 KB, image/gif)
2018-09-13 02:14 UTC, rickpress
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rickpress 2018-09-13 02:12:44 UTC
Description:
Animated Gif's are causing Libreoffice to crash / hang / become very unstable on Windows 10. The version of Libreoffice being used is 6.1.0.3 (the latest from the donwload site. 

Basically some animated gifs work, some animated gifs do not work when being uploaded into an Impress presentation. The files are fine (they work in Powerpoint and other programs). They display and animate a bit but then the program will hang and really slow down (mouse cursor animation changes / real lag in the program) for example. 

Not all animated gifs that I download from the web cause this problem in Impress but many do. 

Not sure what causes it but it's a pretty basic thing that needs to be fixed.

Tried on many PC's at our school in China - problems persist. 



Steps to Reproduce:
1. Open Libreoffice Impress. 
2. Try opening the animated gif files provided. 
3. Impress should hang / slow down / become unrepsonsive. 

Actual Results:
Libreoffice Impress becomes unstable and doesn't work or function properly. 

Expected Results:
Libreoffice will become unstable and hang and crash. 

Animated gif files should display properly and not cause Impress to crash - this is a pretty basic thing and a severe bug which hopefully will get fixed. 



Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
System Information

Version: 6.1.0.3 (x64)
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: en-NZ (en_NZ); Calc: group threaded

Sometimes when moving the mouse cursor over the animated gifs the hang / slow down occurs more.
Comment 1 rickpress 2018-09-13 02:14:07 UTC
Created attachment 144828 [details]
Animated Gif that can cause a crash / slow down

This attachment for example can cause Impress to crash.
Comment 2 Xisco Faulí 2018-09-13 09:16:38 UTC
I can't reproduce it in

Versión: 6.1.0.3
Id. de compilación: efb621ed25068d70781dc026f7e9c5187a4decd1
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threaded

nor in

Version: 6.2.0.0.alpha0+
Build ID: 2da435922f9c1fcf52eb0c1eb3d6f73581e9f793
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

I see a 2 seconds hang when I select the gif but then everything comes back to normal
Comment 3 Telesto 2018-09-13 09:28:35 UTC
This does/can happen when hovering over animated GIF in editing pane (as far I know) As long as GIF image is not hovered over by the mouse cursor, LO runs fine. (see bug 104878 and bug 98500).
Comment 4 rickpress 2018-09-19 01:31:19 UTC
Same problem in Linux with large sized gifs and when you have a lot of animated gifs in a presentation.
Comment 5 rickpress 2018-09-20 02:08:15 UTC
Considering this bug is pretty much the same as the one Tolesto mentions when are these bugs going to get fixed?

Having images such as animated gifs causing machines to hang is a pretty serious bug and isn't something you i'd imagine having running on software that was deemed an alternative to commercial software.
Comment 6 Buovjaga 2018-10-05 16:44:35 UTC
Ok, let's close as duplicate of the open report.

*** This bug has been marked as a duplicate of bug 104878 ***