Bug Hunting Session
Bug 119877 - WRITER, NAVIGATOR -- easy access (right click) to "send outline to clipboard" functionality, PLZ
Summary: WRITER, NAVIGATOR -- easy access (right click) to "send outline to clipboard"...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 119867 (view as bug list)
Depends on:
Blocks: Chapter-Numbering
  Show dependency treegraph
 
Reported: 2018-09-14 13:04 UTC by peter josvai
Modified: 2018-09-23 07:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot from online help (58.73 KB, image/jpeg)
2018-09-19 19:59 UTC, Dieter Praas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description peter josvai 2018-09-14 13:04:41 UTC
I have used this functionality before, but today, when I wanted to use it again, I couldn't... couldn't find it... I even went through the menus, like tools, edit, insert, view...

later on (hours later) I almost accidentally bumped into it in "file / send" ... as "file / send / outline to clipboard"...

- - -// off:
I might be dumb, but I never understood microsoft"s "send" as in "send to desktop" either :) whereas "add to desktop" makes perfect sense for me...
I mean, I would never have looked for "copy outline" in the "file / send" menu...
but regardless, a direct access to it from context menu could be useful...
//- - -

suggestion:

it would be GREAT to have this in the navigator "window", available in context menu... and perhaps move it to the TOOLS menu...
or EDIT ...
Comment 1 Jean-Baptiste Faure 2018-09-16 08:43:08 UTC
*** Bug 119867 has been marked as a duplicate of this bug. ***
Comment 2 Dieter Praas 2018-09-16 20:08:20 UTC
I'm very surprised, that LO offers the posibility to add the outline to clipboard. I agree, that you hardly can find his function. So I agree with Peter. I like the idea
a) to make it more visible in the menu
b) to add it to the headings context menu in the navigator
Comment 3 Heiko Tietze 2018-09-17 09:44:11 UTC
The context menu should not be used to promote functions (otherwise we would have to fill it up much more). But you can customize it yourself.

The Navigator is also not really suited for this so what remains, in my opinion, is to discuss a different position in the main menu.
Comment 4 Cor Nouws 2018-09-19 15:02:16 UTC
(In reply to Heiko Tietze from comment #3)
> The context menu should not be used to promote functions (otherwise we would
> have to fill it up much more). But you can customize it yourself.

Agreeing with that. Context menu is for handling the stuff there.

> The Navigator is also not really suited for this so what remains, in my
> opinion, is to discuss a different position in the main menu.

I do not support the idea that it is extremely hard to find.
The File > Send menu should be reasonably well known, because it also holds sending documents by email..

(In reply to peter josvai from comment #0)
> I have used this functionality before, but today, when I wanted to use it
> again, I couldn't... couldn't find it... I even went through the menus, like

It is on the same place since ages.. OOo 2.0 or so, or maybe earlier. So it looks there is some confusion here ;)
Comment 5 Heiko Tietze 2018-09-19 18:36:27 UTC
(In reply to Cor Nouws from comment #4)
> It is on the same place since ages.. 

So let's keep it there. :-)
Comment 6 Thomas Lendo 2018-09-19 19:46:02 UTC
Peter, is there the need to improve the help files? Have you searched in the help or online?
Comment 7 Dieter Praas 2018-09-19 19:59:26 UTC
Created attachment 145043 [details]
Screenshot from online help

(In reply to Thomas Lendo from comment #6)
> Peter, is there the need to improve the help files? Have you searched in the
> help or online?

I'm not really familiar with the structure of the new help, but when I search for outline I would expect a keyword "outline - send to clipboard" or something like that. But I don't get the result (see screenshot). So I think this could be improved.
Comment 8 peter josvai 2018-09-21 14:07:01 UTC
dear devs, I'm surprised by your rigidness.. or conservatism :) sorry :) 
(I mean, being happily unwilling to change -- see Heiko's response 
"So let's keep it there. :-)"


@ Cor Nouws, 
nice argument: "I do not support the idea that it is extremely hard to find.
The File > Send menu should be reasonably well known, because it also holds sending documents by email.."

I can state that I have never once in my life sent a document using "send -> document by email"... for my workflow and mindset this is alien...

if I want to send a document, I'll go "email app" --> "add as attachment"...
cause what I'm doing is sending an email not editing a document...

BUT STILL, even though one sends documents like this... this funny way..
when you are working on a document and you want to do something with its outline...
your mind will not go anywhere near to something LABELED as "send"...
instead, the logical route will be something similar to this:

document ("file").. "outline"..."tools"... and search for "outline".. or a synonym... but no way for "send"...

but I can sense, this suggestion is totally not welcome :(
Comment 9 peter josvai 2018-09-21 14:26:56 UTC
(In reply to Heiko Tietze from comment #3)
> The context menu should not be used to promote functions (otherwise we would
> have to fill it up much more). But you can customize it yourself.
> 
> The Navigator is also not really suited for this so what remains, in my
> opinion, is to discuss a different position in the main menu.


Why? I mean, why either/or? What is the logic behind that?

why EITHER put it somewhere else in the menu (unless someone makes a comment stating it's not necessary in his opinion :) )
    OR put it in the context menu?

It is widely agreed, I suppose, that context menu is NOT for "promoting" functions...
BUT then, what is it for?
I would say -- and I firmly believe that it makes sense -- that the context menu is to make SUCH functionalities available "at hand" .. which belong to the "context"... what the user is working on/with whatever...

so, in our case, you are using the NAVIGATOR pane...
you are viewing the OUTLINE of a document...
in this "context" the following functions are listed: 

OUTLINE LEVEL
DRAG MODE
DISPLAY

now, is it really a far off concept to put "COPY OUTLINE" in this list?
Isn't it likely that someone wants to copy it?

since the birth of text editors and PCs in general, people have been accustomed to the practice that whatever is before them, text or image, they can COPY it...

SO, as a matter of fact, this might be made possible even directly...
(which, for sure would be way bigger work to do, and would affect lots of other things)

- - - - - - - - - - - - - - - - 
PS:
I repeat.. it works for me...

I can handle such super-minor hardship so easily that I don't even recognize it... I will find "copy outline" even if it is hidden in EDIT / Object, seriously... 
all I need to do is make one FLAG in my mind, so as to remember how to approach this situation, and this FLAG will be "not logical".. and from then on it will work... I'll find it...

the question that "remains" is only how many of 1 000 000 LOW users will actually use this functionality... and how many of us would, were they given an easy access to this functionality (which already exist!!)

thank you for developing LO-W !!
Comment 10 Heiko Tietze 2018-09-22 10:35:48 UTC
Peter, hope you don't take the verdict on your suggestion personally. We have to balance the need of many different users. And to send/copy outline to clipboard is definitely not very common (hope you don't ask me for numbers, let's better say "likely").

The sidebars have the purpose of easy access to properties, and the Navigator is used to list the various objects, arrange it, and to jump to their position. Putting any command there spoils this clear concept.
https://wiki.documentfoundation.org/Design/SideBar

The good news is that you as a power user can easily modify the main and context menus. The customization dialog has been revised recently.
https://help.libreoffice.org/6.1/en-US/text/shared/01/06140100.html

Last but not least, LibreOffice is a community project and your opinion is as relevant as ours from the UX team. So setting the status to REOPEN is okay as well as convincing a developer to patch :-)
https://www.libreoffice.org/community/get-involved/
Comment 11 Cor Nouws 2018-09-23 07:47:11 UTC
(In reply to Heiko Tietze from comment #10)

> Last but not least, LibreOffice is a community project and your opinion is
> as relevant as ours from the UX team. So setting the status to REOPEN is
> okay as well as convincing a developer to patch :-)
> https://www.libreoffice.org/community/get-involved/

I've been thinking some more about this. And really doubt about that.
If we implement "Send outline to .." in the context menu in the Navigator, we can implement "Outline numbering", Change styles maybe ..
So before a possible OK, we really need to oversee where this could possibly lead, hopefully ever end :) - don't you think?