Download it now!
Bug 119892 - Fonts in LibreOffice Writer 6.1.1 are wrong
Summary: Fonts in LibreOffice Writer 6.1.1 are wrong
Status: RESOLVED DUPLICATE of bug 117411
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.1.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-14 22:46 UTC by drexlar
Modified: 2018-09-15 21:22 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Writer document prepared with version 6.0.6.2 (21.79 KB, application/vnd.oasis.opendocument.text)
2018-09-15 12:25 UTC, drexlar
Details
Screen capture of two pages doc prepared with 6.0.6.2 as seen by 6.1.1 (294.88 KB, image/jpeg)
2018-09-15 12:27 UTC, drexlar
Details
Screen capture of first page prepared with 6.0.6.2 as seen by 6.1.1 (103.54 KB, image/png)
2018-09-15 12:30 UTC, drexlar
Details
Screen capture of second page prepared with 6.0.6.2 as seen by 6.1.1 (67.85 KB, image/png)
2018-09-15 12:31 UTC, drexlar
Details
List of fonts available in Writer 6.1.1 (33.19 KB, image/png)
2018-09-15 12:37 UTC, drexlar
Details
Screen capture of page 12 of the original document in 6.0.6.2 (294.88 KB, image/jpeg)
2018-09-15 12:59 UTC, drexlar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description drexlar 2018-09-14 22:46:49 UTC
Description:
One hour ago I tested LibreOffice 6.1.1 in Ubuntu 18.04.1. I have a document of 116 pages and the first thing I noticed is a problem with fonts. Which is not present in LibreOffice Writer 6.0.6.2 in Ubuntu 16.04.5. Both operating systems are installed in the same machine, my machine, an HP Envy 17-s151nr with 12 GB RAM and two hard disks of 2 TB each. The problem is that a text that was in blue, Arial 10 with a paragraph color gray in Writer 6.1.1 appeared as if the height of the font were trimmed. The other problem that I saw is that the fonts available are not the ones that we use in the West but there were fonts described in English at left and on the right pictorial elements used in languages like Pakistani, Hindu, etc. I could not find Arial in the list of Writer 6.1.1 available fonts. 

Steps to Reproduce:
1. Open a Writer document in LibreOffice 6.1.1 that was prepared in a previous version, the last version of Office Writer I can say is stable is 6.0.6.2
2. You will see for yourself what I described in the description
3.

Actual Results:
Not available 

Expected Results:
I expected LibreOffice Writer 6.1.1 to behave as version 6.0.6.2


Reproducible: Always


User Profile Reset: No



Additional Info:
I will attach a Writer document of two or three pages where you can check the bug in Writer 6.1.1.

I am no longer in Ubuntu 18.04.1 where LibreOffice 6.1.1 is installed. I am now in Ubuntu 16.04.5 with LibreOffice 6.0.6.2. I will append below the About info since this is the Writer version that works flawlessly:

Version: 6.0.6.2
Build ID: 1:6.0.6-0ubuntu0.16.04.1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group

I will switch to Ubuntu 18.04.1 and use LibreOffice Writer 6.1.1 and send an attachment containing the pages as shown in Writer 6.0.6.2 and 6.1.1 so you can see what I described in the description.
Comment 1 drexlar 2018-09-15 12:25:33 UTC
Created attachment 144887 [details]
Writer document prepared with version 6.0.6.2

I will attach a screen capture of the same document as seen with Writer 6.1.1 so you can see the distortion generated by 6.1.1 version.
Comment 2 drexlar 2018-09-15 12:27:50 UTC
Created attachment 144888 [details]
Screen capture of two pages doc prepared with 6.0.6.2 as seen by 6.1.1

Screen capture of first page of interest
Comment 3 drexlar 2018-09-15 12:30:36 UTC
Created attachment 144889 [details]
Screen capture of first page prepared with 6.0.6.2 as seen by 6.1.1

Attachment 144888 [details] was attached by error. Dismiss please this attachment.
Comment 4 drexlar 2018-09-15 12:31:59 UTC
Created attachment 144890 [details]
Screen capture of second page prepared with 6.0.6.2 as seen by 6.1.1
Comment 5 drexlar 2018-09-15 12:37:02 UTC
Created attachment 144891 [details]
List of fonts available in Writer 6.1.1

The screen capture shows the list of fonts available in Writer version 6.1.1. I do not understand why those fonts are appearing if the locale is defined as English US.

Help > About shows the following:

Version: 6.1.1.2
Build ID: 1:6.1.1~rc2-0ubuntu0.18.04.1~lo3
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group threaded
Comment 6 drexlar 2018-09-15 12:59:45 UTC
Created attachment 144892 [details]
Screen capture of page 12 of the original document in 6.0.6.2

This screen capture shows page 12 of the original document prepared with Writer 6.0.6.2. The document is 116 pages long. Compare this with attachment 144889 [details] which shows this page as seen by version 6.1.1. Notice that 6.1.1 shows document as 113 pages long, such is the distortion produced by the faulty font behaviour.
Comment 7 Jean-Baptiste Faure 2018-09-15 21:22:18 UTC
Not reproducible for me with LibreOffice 6.1.1 from Ubuntu PPA under Ubuntu 18.04 x86-64.
That said there is a bug in the Liberation font provided by Ubuntu 18.04. See https://bugs.documentfoundation.org/show_bug.cgi?id=117411
and its workaround.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 117411 ***