Bug 119905 - Infobar: text slightly overlaps the button
Summary: Infobar: text slightly overlaps the button
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: All All
: medium normal
Assignee: rptr
URL:
Whiteboard: target:6.3.0
Keywords: difficultyBeginner, easyHack, topicUI
Depends on:
Blocks: Infobar-UX
  Show dependency treegraph
 
Reported: 2018-09-16 14:20 UTC by Dennis Holierhoek
Modified: 2019-05-18 14:50 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of Dutch Ingress reading a read-only PPt (147.65 KB, image/png)
2018-09-16 14:20 UTC, Dennis Holierhoek
Details
Screenshot of Dutch Impress 6.0.6 reading a read-only PPT (109.62 KB, image/png)
2018-09-25 10:44 UTC, Dennis Holierhoek
Details
How it looks in LibreOffice 6.2 master in English (10.30 KB, image/png)
2018-11-12 14:53 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Holierhoek 2018-09-16 14:20:55 UTC
Created attachment 144907 [details]
Screenshot of Dutch Ingress reading a read-only PPt

Hello everybody,

On the Dutch version of Ingress I have this problem on my XGA (1024 x 768 resoulution) display:

The text "Document is geopend in de modus alleen-lezen" ("Document is opened in read-only mode" overlaps the button "Document bewerken" ("Edit Document")

See the attachment to see what happened

Cheers,

Dennis
Comment 1 Julien Nabet 2018-09-17 07:29:27 UTC
Dennis: could you give a try to a more recent LO version 6.0.6 or 6.1.0?
Comment 2 Dennis Holierhoek 2018-09-25 10:44:24 UTC
Created attachment 145159 [details]
Screenshot of Dutch Impress 6.0.6 reading a read-only PPT
Comment 3 Dennis Holierhoek 2018-09-25 10:46:56 UTC
(In reply to Julien Nabet from comment #1)
> Dennis: could you give a try to a more recent LO version 6.0.6 or 6.1.0?

Hello Julien,

I updated my Kubuntu 18.04 system this weekend. "apt show libreoffice" shows me the following:
[..]
Version: 1:6.0.6-0ubuntu0.18.04.1
[..]

As you can see in the new screenshot (that I actually did not include in this message but in the message I just posted, sorry for that), the problem still persists

Thanks in advance,

Dennis
Comment 4 Cor Nouws 2018-10-28 21:58:31 UTC
Hi Dennis,

(In reply to Dennis Holierhoek from comment #0)
> The text "Document is geopend in de modus alleen-lezen" ("Document is opened
> in read-only mode" overlaps the button "Document bewerken" ("Edit Document")
I guess/expect the glitch disappears when one of the side bars is closed? It looks as if text on the info/notification bar just doesn't scale if it is too wide.
Comment 5 Xisco Faulí 2018-11-12 14:53:00 UTC
it overlaps the button a little bit. Same with English if the windows is resized
Comment 6 Xisco Faulí 2018-11-12 14:53:27 UTC
Created attachment 146568 [details]
How it looks in LibreOffice 6.2 master in English
Comment 7 Xisco Faulí 2018-11-12 14:54:31 UTC
@heiko, I thought you could be interested in this issue...
Comment 8 Heiko Tietze 2018-11-13 09:28:40 UTC
The issue is clear, verbose text potentially exceeds the screen real estate. And the solution is to wrap and adjust the bar height too.
Comment 9 Heiko Tietze 2018-11-13 09:39:20 UTC
Let's make this an easy hack

sfx2/source/dialog/infobar.cxx => SfxInfoBarWindow::Resize()

I would think about DrawText() with DT_WORDBREAK but there might be alternative solutions in the LibreOffice sources.
Comment 10 Commit Notification 2019-03-22 15:19:12 UTC
Rasmus Jonsson committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/c92bfbf9506681468a471563a47eb84c6944a104%5E%21

tdf#119905 Infobar text overlap

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.