Bug 119915 - Make it easier to work with different fonts
Summary: Make it easier to work with different fonts
Status: RESOLVED DUPLICATE of bug 91130
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fonts-Name-Combobox
  Show dependency treegraph
 
Reported: 2018-09-17 00:51 UTC by J22Gim
Modified: 2018-09-17 07:15 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description J22Gim 2018-09-17 00:51:06 UTC
Description:
It would be great if Writer (I guess can be applied to all LO apps) remembered the commonly used fonts in the document so the user doesn't have to manually search for them every time.

Steps to Reproduce:
1. Open a document and write several things with different fonts.
2. Now let's say you want to change the font of a given text so you click into the drop-down menu which displays all installed fonts

Actual Results:
Fonts are (almost) alphabetically sorted (ascending). Thus in order to get the font you want you have to either a) scroll down until you find it, or b) write the name if you remember it exactly.

Expected Results:
It would make sense if Writer offered two kind of fonts at the beginning of the list, a) fonts already used in the current document and b) fonts used in the current session. If this was the case, just by clicking into the font drop-down menu I can see the last fonts (or fonts present in the current document), thus making the editing so much faster.


Reproducible: Always


User Profile Reset: No



Additional Info:
For example I work a lot with Liberation sans. The problem is, there are many Liberation fonts (Liberation mono, Liberation Serif, etc.) Thus every time I want to change the font to Liberation Sans I have to actually Write "Liberation sa" in the font name box to benefit from the Autocomplete option... This is time consuming and cumbersome. Some may say "this is what Styles are for", but it is not always justified that you need to create a style just for the font..
Comment 1 Dieter Praas 2018-09-17 07:15:15 UTC
There are still some ideas about it (see https://design.blog.documentfoundation.org/2018/02/18/improvements-font-listing/) and it is similar to bug 91130. I I would treat your bug as a duplicate. Please feel free to reopen it, if you don't agree.

*** This bug has been marked as a duplicate of bug 91130 ***