Bug Hunting Session
Bug 119989 - Crash in: SwIndex::SwIndex(SwIndexReg * const,long)
Summary: Crash in: SwIndex::SwIndex(SwIndexReg * const,long)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2018-09-19 17:17 UTC by Nick Beneker
Modified: 2019-01-14 16:20 UTC (History)
7 users (show)

See Also:
Crash report or crash signature: ["SwIndex::SwIndex(SwIndexReg * const,long)", "SfxBroadcaster::Broadcast(SfxHint const &)"]


Attachments
this is the file that I was trying to modify (17.95 KB, application/zip)
2018-09-20 12:59 UTC, Nick Beneker
Details
this is the screen play of the error (3.13 MB, video/avi)
2018-09-20 13:01 UTC, Nick Beneker
Details
minimal sample (20.41 KB, application/vnd.oasis.opendocument.text)
2018-09-20 14:01 UTC, Xisco Faulí
Details
bt with debug symbols (11.32 KB, text/plain)
2018-09-29 19:10 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Beneker 2018-09-19 17:17:43 UTC
This bug was filed from the crash reporting server and is br-107831b7-d870-4a6f-b96a-b03f3727119b.
=========================================
Consistent crashes whenever I perform the following sequence:

Insert rows to a table

Copy content from existing rows to the new rows

Attempt to modify content of any of the rows

using version 6.0.5.2 (x64) ofLibreOffice Writer
Comment 1 Xisco Faulí 2018-09-19 21:31:24 UTC
Thanks for reporting the issue.
Do you reproduce it with a blank document or with a specific document? If so, could you please attach it.
OTOH, Could you please create and attach a screencast showing the steps?
There are various free screencast software available for use, including Camstudio (Windows), Jing (Mac), Simple Screen Recorder (Linux) or screencast-o-matic.com (Web).

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested screencast is provided.
Comment 2 Julien Nabet 2018-09-20 06:55:39 UTC
Michael: a lot of bt of the crashreports page shows DocumentRedlineManager.
Having noticed your recent work about this, thought you might be interested in this one.
I mean, it's perhaps already fixed in master.
Comment 3 Nick Beneker 2018-09-20 12:59:50 UTC
Created attachment 145065 [details]
this is the file that I was trying to modify
Comment 4 Nick Beneker 2018-09-20 13:01:31 UTC
Created attachment 145066 [details]
this is the screen play of the error

the last step was to select one of the cell in order to modify it
Comment 5 Xisco Faulí 2018-09-20 14:01:06 UTC
So it crashes for me when I undo the paste action

Versión: 6.1.1.2
Id. de compilación: 5d19a1bfa650b796764388cd8b33a5af1f5baa1b
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threaded

Steps to reproduce with the minimal file attached
1. Open the file
2. Select the rows with content in the first page and copy
3. select the last three rows without content in the first page
4. Paste
5. Undo the action

Crash!

http://crashreport.libreoffice.org/stats/crash_details/625b8d80-2012-44dc-980a-28c69c921c1b
Comment 6 Xisco Faulí 2018-09-20 14:01:28 UTC
Created attachment 145067 [details]
minimal sample
Comment 7 Xisco Faulí 2018-09-21 23:27:28 UTC
it has taken me a while to bisect it ( sometimes it crashed, sometimes not ) but I think I've found the commit introduced the crash... I've reverted it locally and it no longer crashes following the steps from comment 5.

Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2c3dfd9d3bafc6ad84d750c7bec935b5b164e7f7

author	Ashod Nakashian <ashod.nakashian@collabora.co.uk>	2017-08-25 20:47:30 -0400
committer	Ashod Nakashian <ashnakash@gmail.com>	2017-08-28 03:50:54 +0200
commit	2c3dfd9d3bafc6ad84d750c7bec935b5b164e7f7 (patch)
tree	8a7f1e5875063abc42b4a4a5ac0e9dc0572b6c9f
parent	3eb31b506a2860eba3a578333a6486ee2a518c1a (diff)
sw: invalidate paragraph signature on edit

Bisected with: bibisect-linux64-6.0 

Adding Cc: to Ashod Nakashian
Comment 8 Julien Nabet 2018-09-29 19:10:18 UTC
Created attachment 145269 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I got an assert with the minimal file.
I had the assert just before the undo.
Comment 9 Xisco Faulí 2018-11-19 23:06:56 UTC
Still reproducible in

Version: 6.2.0.0.beta1+
Build ID: 268364e35100b559f42d8c02b930c5cca1c84be7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

with a clear profile
Comment 10 raal 2019-01-11 12:33:24 UTC
(In reply to Xisco Faulí from comment #5)
> So it crashes for me when I undo the paste action
> 
> Versión: 6.1.1.2
> Id. de compilación: 5d19a1bfa650b796764388cd8b33a5af1f5baa1b
> Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
> Configuración regional: es-ES (es_ES); Calc: group threaded
> 
> Steps to reproduce with the minimal file attached
> 1. Open the file
> 2. Select the rows with content in the first page and copy
> 3. select the last three rows without content in the first page
> 4. Paste
> 5. Undo the action
> 
> Crash!
> 
> http://crashreport.libreoffice.org/stats/crash_details/625b8d80-2012-44dc-
> 980a-28c69c921c1b

No crash with Version: 6.3.0.0.alpha0+
Build ID: 17dd2662ccfa9d04efbea74e5d7548db5b2126d4
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win;
Comment 11 Cor Nouws 2019-01-11 12:45:00 UTC
(In reply to raal from comment #10)
 
> No crash with Version: 6.3.0.0.alpha0+
> Build ID: 17dd2662ccfa9d04efbea74e5d7548db5b2126d4
> CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win;
Also no crash for me in Version: 6.3.0.0.alpha0+
Build ID: 62142168e42a050d052d7d75fafd8f6e9cf2a1af
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-01-10_12:30:00
Locale: nl-NL (nl_NL.UTF-8); UI-Language: en-US
Calc: threaded
Comment 12 Xisco Faulí 2019-01-14 15:19:04 UTC
I can't reproduce it in

Version: 6.1.4.2
Build ID: 1:6.1.4-0ubuntu0.16.04.1~lo2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

nor in

Version: 6.3.0.0.alpha0+
Build ID: a0210c5c5e8fd47b55567a8b18788d57d2b7decb
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Closing as RESOLVED WORKSFORME

@Nick Beneker, could you please check it on your side?
Comment 13 Nick Beneker 2019-01-14 16:20:22 UTC
I do not seem to be able to reproduce it.  I have not seen a recurrence of the issue in over a month. So I think it is safe to close. 

Thank you for addressing this.