Bug Hunting Session
Bug 120007 - Style is removed when clearing direct formatting of numbered list and then saving to file
Summary: Style is removed when clearing direct formatting of numbered list and then sa...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Clear-Formatting
  Show dependency treegraph
 
Reported: 2018-09-20 11:40 UTC by pnsaevik
Modified: 2019-10-14 09:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pnsaevik 2018-09-20 11:40:58 UTC
Description:
If a list has a named style, it is removed when applying "Clear Direct Formatting". The change only appears when the file is saved and reloaded.

Steps to Reproduce:
To reproduce:

- Open LibreOffice Writer
- Turn on numbered list (F12)
- Change to a named style, such as "Text Body"
- Write two items:
    1. Test
    2. Test
- Select all text and apply "Clear Direct Formatting" (Ctrl-M)
- The style of the text appears unchanged
- Save and reload the file
- The style of the text is now "Default Style"

Actual Results:
The style of the text is removed and replaced with "Default Style"

Expected Results:
The style should be the same as before I saved the file.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Buovjaga 2018-10-13 12:32:21 UTC
Repro.

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: b752a93acff31c824bcec4233a8dd9bee014ca7d
CPU threads: 8; OS: Linux 4.18; UI render: default; VCL: gtk3_kde5; 
Locale: fi-FI (fi_FI.UTF-8); Calc: threaded
Built on 12 October 2018

Arch Linux 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 2 QA Administrators 2019-10-14 02:27:29 UTC Comment hidden (obsolete)
Comment 3 pnsaevik 2019-10-14 06:12:27 UTC
As requested, I downloaded the most recent version of OpenOffice and can confirm that the bug is gone. Nice work :-)


Version: 6.3.2.2 (x64)
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: nb-NO (nb_NO); UI-Language: en-US
Calc: threaded
Comment 4 Buovjaga 2019-10-14 09:35:24 UTC
Yep, confirmed the problem is gone

Arch Linux 64-bit
Version: 6.4.0.0.alpha0+
Build ID: 137e14ec4c3d3258df3802426b5ffe469f7fbde3
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kf5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 14 October 2019