Bug 120010 - Search field should follow localized AutoCorrect options for single and double quotes
Summary: Search field should follow localized AutoCorrect options for single and doubl...
Status: RESOLVED DUPLICATE of bug 116763
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-20 14:15 UTC by Thomas Lendo
Modified: 2018-10-13 10:02 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2018-09-20 14:15:27 UTC
Now it is impossible to search for single and double quotes that are typed in the search field with normal keyboard characters because single and double quotes are replaced by other characters in normal text due to the localized options in the AutoCorrect options.

English keyboard layout: ' has its own key, " is shift+' according to https://upload.wikimedia.org/wikipedia/commons/5/51/KB_United_States-NoAltGr.svg
German keyboard layout: " is shift+2 and ' is shift+# according to https://upload.wikimedia.org/wikipedia/commons/3/36/KB_Germany.svg

Steps to reproduce:
1) Type or copy the following text into a Writer document.
English text:  Test test “test” test ‘test’ test.
German text:   Test test „test“ test ‚test‘ test.
French text :  Test test « test » test ‘test’ test.

2) Open search with ctrl+f.
3) Type " into the search field and search for it.
4) Type ' into the search field and search for it.

Actual result:
Nothing will be found.

Expected result:
As LibreOffice replaces these characters automatically, the search field should respect that and find the auto-corrected equivalents. Maybe an option in the find dialog can be introduced where the user can specify that only the original "'" and not the auto-corrected localized equivalents should be found. In my view, the user usually wants to find what is in the document--that's what the user writes or what LibreOffice auto-corrects.
Comment 1 Buovjaga 2018-10-13 10:02:18 UTC

*** This bug has been marked as a duplicate of bug 116763 ***