Bug 120011 - Certain special fonts expand cursor to 14cm
Summary: Certain special fonts expand cursor to 14cm
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.1.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fonts
  Show dependency treegraph
 
Reported: 2018-09-20 15:52 UTC by Dino
Modified: 2018-12-28 16:56 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example PDF file of the problem (23.08 KB, application/pdf)
2018-09-20 16:07 UTC, Dino
Details
One TTF file which cases the problem (10.54 KB, application/x-font-ttf)
2018-09-20 16:09 UTC, Dino
Details
Arrows1 font modified in Fontlab (13.27 KB, application/x-font-ttf)
2018-09-24 18:27 UTC, LibreTraining
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dino 2018-09-20 15:52:12 UTC
Description:
When I insert special caracters, using certain TrueType TTF fonts, within my text, these symbols stretch about 17 cm down my page.  The TTF fonts I have trouble with all come from a CorelDraw 9 CD.  I even recopied these fonts from the original CD into the C:\WINDOWS\FONTS folder.  I tried converting my ODT to a DOCX file but the problem remains.  I even created a new ODT document ... the problem remains.  Nothing helped.  Standard Windows fonts such as Webding and the three Wingding fonts work perfectly.

This bug started about 8 months ago.  I just upgraded to LibreOffice 6.1.1.2 and my problem remains.  Please note that my problem, when opening the same ODT file in OpenOffice 4.1.5, everything is perfect ... no stretched symbols.  I'm using a 64 bits Windows 10 version 1803 on a HP notebook.

Steps to Reproduce:
1. Create a new document.
2. Click Insert then Special Charaters.
3. Select Arrows 1 or Food or Household font and insert a symbol.

Actual Results:
Some special characters stretch to 17 cm long.

Expected Results:
Should remain the standard font size selected for the rest of the text (ex. 12).


Reproducible: Always


User Profile Reset: No



Additional Info:
see above.
Comment 1 Dino 2018-09-20 16:07:08 UTC
Created attachment 145071 [details]
Example PDF file of the problem
Comment 2 Dino 2018-09-20 16:09:05 UTC
Created attachment 145074 [details]
One TTF file which cases the problem
Comment 3 Dieter Praas 2018-09-22 05:12:08 UTC
I confirm it with the font Arrows1: Formatting mark has the correct size, but cursor is around 14cm

But I think it's not only about special characters. I justed opened an new document and changed the font to Arrows1 and the bug appeared.


Version: 6.2.0.0.alpha0+ (x64)
Build ID: 62cd86977ca41677c56fb2d1f97bb1c5cbdbd416
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-09-20_02:34:32
Locale: en-US (de_DE); Calc: CL

and

Version: 6.0.6.2 (x64)
Build-ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group


Situation in LO 5.4 is different: I can't add special characrer from font Arrwos1 (special character list is empty) but when I open the document createdwith LO 6, the bug is still there
Comment 4 LibreTraining 2018-09-24 18:27:35 UTC
Created attachment 145142 [details]
Arrows1 font modified in Fontlab

It appears that this font is quite old, has some metrics issues, and it is not a Unicode font. 

Opened it in Fontlab and noticed an odd setting: Safe bottom = -40000
My guess is that is a missing setting, not the actual setting.
So I let Fontlab determine what it thought it should be: -93
Renamed and exported the font.
Fontlab converted it to OpenType and Unicode.

Installed the modified font - and it does not have the issue.

Fontlab has moved some things around, but it all appears to be there.
And the insert Special Characters seems to work properly.
Did not test thoroughly.

You can install both fonts as this one has been renamed to Arrows1Fontlab.

So to summarize - old font, not unicode, with some odd metrics issues.

.
Comment 5 Xisco Faulí 2018-10-17 14:43:35 UTC
@LibreTraining, thanks for the analysis in comment 4.

@Khaled, should it be closed as RESOLVED NOTOURBUG ?
Comment 6 Khaled Hosny 2018-10-19 00:36:44 UTC
I guess so. The font has an OS/2.usWinDescent value of 65447, which is rather odd. Looks like 0xFFFE - 89, so looks like some tool screwed up while encoding the number in the TTF file.