Bug 120012 - FILESAVE: Formatting and/or data validation, positioned after last non-empty cell, is lost when saving to XLS or XLSX
Summary: FILESAVE: Formatting and/or data validation, positioned after last non-empty ...
Status: RESOLVED DUPLICATE of bug 46738
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 41425
Blocks: XLSX Cell-Validity XLS
  Show dependency treegraph
 
Reported: 2018-09-20 16:05 UTC by Gabor Kelemen
Modified: 2018-10-01 15:57 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments
Example ods file with 2000 rows of validation (9.43 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-09-20 16:05 UTC, Gabor Kelemen
Details
The same file saved as xlsx with LO 6.2 (10.75 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-09-20 16:07 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2018-09-20 16:05:55 UTC
Created attachment 145070 [details]
Example ods file with 2000 rows of validation

+++ This bug was initially created as a clone of Bug #41425 +++

Hi. I have a file with lots of data validation, I open it in LibreOffice, and I do nothing else but save it as either XLS or XLSX.

The resulting XLS or XLSX now have no data validation.

---
This bug is here as a reminder to find a proper solution to saving formatting and data validation to XLSX format. The workaround for Bug #41425 works for the next 1000 rows after the last one, which should cover most user needs. 

However we should not settle for a workaround, but support this for all and every single rows.
Comment 1 Gabor Kelemen 2018-09-20 16:07:43 UTC
Created attachment 145072 [details]
The same file saved as xlsx with LO 6.2

Validation ends in row 1003 with:

Version: 6.2.0.0.alpha0+
Build ID: a27ae800fed5a974c9b255f7ce2b38ec2dbaa426
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: hu-HU (hu_HU); Calc: CL

From bibisect-win32-6.2 repo.
Comment 2 Gabor Kelemen 2018-10-01 15:57:26 UTC
Silly me, there is already one bug left open for this. Sorry for the spam :(.

*** This bug has been marked as a duplicate of bug 46738 ***