Bug Hunting Session
Bug 120024 - Writer table - letters get cut off on bottom row of page
Summary: Writer table - letters get cut off on bottom row of page
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables
  Show dependency treegraph
 
Reported: 2018-09-21 01:45 UTC by Andrew
Modified: 2019-09-24 06:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screen shot (13.21 KB, image/png)
2018-09-21 01:46 UTC, Andrew
Details
source file (159.00 KB, application/msword)
2018-09-21 01:47 UTC, Andrew
Details
6.3.0 screen shot (26.00 KB, image/png)
2019-09-24 03:36 UTC, Andrew
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew 2018-09-21 01:45:56 UTC
Description:
I have a multi-page table, with Heading rows repeating at the top.  On one of the pages, the letters on the bottom row of the table are getting cut off below the bottom of the page boundary.  See screen shot.

Steps to Reproduce:
1.I wasn't able to reproduce.  After exiting Writer and re-opening the document, the table row CORRECTLY appeared at the top of the next page.  It appears some flow and refresh logic isn't happening correctly.
2.
3.

Actual Results:
Text on bottom row is getting cut off below the bottom page margin

Expected Results:
Row should get bumped to next page if it doesn't fit inside the page margin.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.0.3 (x64)
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: en-US (en_US); Calc: group threaded
Comment 1 Andrew 2018-09-21 01:46:46 UTC
Created attachment 145082 [details]
screen shot
Comment 2 Andrew 2018-09-21 01:47:28 UTC
Created attachment 145083 [details]
source file
Comment 3 Dieter Praas 2018-09-21 07:14:56 UTC
I can't confirm it with your document and

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 62cd86977ca41677c56fb2d1f97bb1c5cbdbd416
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-09-20_02:34:32
Locale: en-US (de_DE); Calc: CL
Comment 4 Telesto 2018-09-21 11:48:43 UTC
Repro
Version: 6.2.0.0.alpha0+
Build ID: 76bf3939b0583212a56c317c85aea110f8ac6fee
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2018-07-27_06:01:47
Locale: nl-NL (nl_NL.UTF-8); Calc: group threaded

and with
Version: 4.3.7.2
Build ID: 8a35821d8636a03b8bf4e15b48f59794652c68ba

STR
1. Open the attached file
2. Scroll down to page 38
3. Press Enter before "Hop" after Appendix A
4. Content moves to the next page (with layout similar to the screenshot)
Comment 5 Telesto 2018-09-22 11:38:29 UTC
Repro with
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 6 QA Administrators 2019-09-23 02:54:20 UTC Comment hidden (obsolete)
Comment 7 Andrew 2019-09-24 03:35:44 UTC
Opened a newer version of the same file in Windows 6.3.0.4 x64. In the affected table. it is CORRECTLY pulling "U.S. Hallertau" to the top of the next page now. See new screen shot
Comment 8 Andrew 2019-09-24 03:36:21 UTC
Created attachment 154398 [details]
6.3.0 screen shot
Comment 9 Andrew 2019-09-24 03:39:26 UTC
I also added a blank line in a table cell ABOVE "U.K. Kent GOldings", and it CORRECTLY pulled that row to the top of the next page.

Was there an intentional patch for this, of dumb luck that it seems to be fixed for this document?
Comment 10 Dieter Praas 2019-09-24 06:04:52 UTC
(In reply to Andrew from comment #9)
> I also added a blank line in a table cell ABOVE "U.K. Kent GOldings", and it
> CORRECTLY pulled that row to the top of the next page.
> 
> Was there an intentional patch for this, of dumb luck that it seems to be
> fixed for this document?

Set status to RESOLVED WORKSFORME because of comment 9