Download it now!
Bug 120039 - Shift+F3 not working as expected: Changing other capitals than selected
Summary: Shift+F3 not working as expected: Changing other capitals than selected
Status: RESOLVED DUPLICATE of bug 49033
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-21 20:15 UTC by pibarnas
Modified: 2018-10-24 21:00 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pibarnas 2018-09-21 20:15:11 UTC
Description:
Shift+F3 is a very handly way to make capital of the first sentence's letter or all of them. In LO past versions, it was just select the word, or the sentence and click the shortcut and it's done and it toggles capital first letter, all or none of them. I used to use it a lot, writing a text. Now, in LO 6.1.* versions, I select the words in the sentence that I want to capitalize, but after the shortcut press, it capitalize the selected, but toggles other letter out of the selection, which is the behavior not expected, turning the shorcut unable to use. Since LO 6.1.0. 

Steps to Reproduce:
1. Mark a word in a sentence of a paragraph, specially if it has other capitals other than the selection you made. 
2.Press shift+F3 three times.
3. See what happens with the word with capitals that's out of the karked word that you want to change (that's the only word that must be altered)

Actual Results:
Selected word and those ones out of the selection will be altered with the shortcut.

Expected Results:
The marked word or sentence will change with sequential presses of the shorcut, as well as other capitalized words in the sentence not marked or in the paragraph, which is not the behavior expected.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Only the word or letter selected must be altered with shortcut, not those ones not selelected or marked.

The behavior is totally different on LO 6.0.6 (the correct one).
Comment 1 Mike Kaganski 2018-09-21 20:40:27 UTC

*** This bug has been marked as a duplicate of bug 119495 ***
Comment 2 V Stuart Foote 2018-10-24 21:00:57 UTC

*** This bug has been marked as a duplicate of bug 49033 ***